USN-5674-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5674-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5674-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5674-1
Related
Published
2022-10-13T14:06:12.453552Z
Modified
2022-10-13T14:06:12.453552Z
Summary
xmlsec1 vulnerability
Details

It was discovered that XML Security Library incorrectly handled certain input documents. An attacker could possibly use this issue to obtain sensitive information or cause a denial of service.

References

Affected packages

Ubuntu:Pro:16.04:LTS / xmlsec1

Package

Name
xmlsec1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.20-2ubuntu4+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libxmlsec1-gnutls": "1.2.20-2ubuntu4+esm1",
            "libxmlsec1-gcrypt": "1.2.20-2ubuntu4+esm1",
            "libxmlsec1-nss": "1.2.20-2ubuntu4+esm1",
            "libxmlsec1-dev": "1.2.20-2ubuntu4+esm1",
            "libxmlsec1": "1.2.20-2ubuntu4+esm1",
            "libxmlsec1-openssl": "1.2.20-2ubuntu4+esm1",
            "xmlsec1": "1.2.20-2ubuntu4+esm1"
        }
    ]
}