USN-5686-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5686-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5686-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5686-1
Related
Published
2022-10-18T17:59:28.228710Z
Modified
2022-10-18T17:59:28.228710Z
Summary
git vulnerabilities
Details

Cory Snider discovered that Git incorrectly handled certain symbolic links. An attacker could possibly use this issue to cause an unexpected behaviour. (CVE-2022-39253)

Kevin Backhouse discovered that Git incorrectly handled certain command strings. An attacker could possibly use this issue to arbitrary code execution. (CVE-2022-39260)

References

Affected packages

Ubuntu:22.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.34.1-1ubuntu1.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-sysvinit": "1:2.34.1-1ubuntu1.5",
            "git-daemon-run": "1:2.34.1-1ubuntu1.5",
            "git-email": "1:2.34.1-1ubuntu1.5",
            "git-mediawiki": "1:2.34.1-1ubuntu1.5",
            "git": "1:2.34.1-1ubuntu1.5",
            "git-svn": "1:2.34.1-1ubuntu1.5",
            "gitk": "1:2.34.1-1ubuntu1.5",
            "git-cvs": "1:2.34.1-1ubuntu1.5",
            "gitweb": "1:2.34.1-1ubuntu1.5",
            "git-man": "1:2.34.1-1ubuntu1.5",
            "git-gui": "1:2.34.1-1ubuntu1.5",
            "git-all": "1:2.34.1-1ubuntu1.5",
            "git-doc": "1:2.34.1-1ubuntu1.5"
        }
    ]
}

Ubuntu:20.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.25.1-1ubuntu3.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.25.1-1ubuntu3.6",
            "git-email": "1:2.25.1-1ubuntu3.6",
            "git-mediawiki": "1:2.25.1-1ubuntu3.6",
            "git": "1:2.25.1-1ubuntu3.6",
            "git-el": "1:2.25.1-1ubuntu3.6",
            "git-cvs": "1:2.25.1-1ubuntu3.6",
            "git-doc": "1:2.25.1-1ubuntu3.6",
            "gitk": "1:2.25.1-1ubuntu3.6",
            "git-daemon-sysvinit": "1:2.25.1-1ubuntu3.6",
            "git-svn": "1:2.25.1-1ubuntu3.6",
            "gitweb": "1:2.25.1-1ubuntu3.6",
            "git-man": "1:2.25.1-1ubuntu3.6",
            "git-gui": "1:2.25.1-1ubuntu3.6",
            "git-all": "1:2.25.1-1ubuntu3.6"
        }
    ]
}

Ubuntu:18.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.17.1-1ubuntu0.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.17.1-1ubuntu0.13",
            "git-email": "1:2.17.1-1ubuntu0.13",
            "git-mediawiki": "1:2.17.1-1ubuntu0.13",
            "git": "1:2.17.1-1ubuntu0.13",
            "git-el": "1:2.17.1-1ubuntu0.13",
            "git-cvs": "1:2.17.1-1ubuntu0.13",
            "git-doc": "1:2.17.1-1ubuntu0.13",
            "gitk": "1:2.17.1-1ubuntu0.13",
            "git-daemon-sysvinit": "1:2.17.1-1ubuntu0.13",
            "git-svn": "1:2.17.1-1ubuntu0.13",
            "gitweb": "1:2.17.1-1ubuntu0.13",
            "git-man": "1:2.17.1-1ubuntu0.13",
            "git-gui": "1:2.17.1-1ubuntu0.13",
            "git-all": "1:2.17.1-1ubuntu0.13"
        }
    ]
}