USN-5731-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5731-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5731-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5731-1
Related
Published
2022-11-17T13:14:45.603942Z
Modified
2022-11-17T13:14:45.603942Z
Summary
multipath-tools vulnerabilities
Details

It was discovered that multipath-tools incorrectly handled symlinks. A local attacker could possibly use this issue, in combination with other issues, to escalate privileges. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and Ubuntu 22.10. (CVE-2022-41973)

It was discovered that multipath-tools incorrectly handled access controls. A local attacker could possibly use this issue, in combination with other issues, to escalate privileges. (CVE-2022-41974)

References

Affected packages

Ubuntu:22.04:LTS / multipath-tools

Package

Name
multipath-tools

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.8-1ubuntu1.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "kpartx-boot": "0.8.8-1ubuntu1.22.04.1",
            "multipath-tools-boot": "0.8.8-1ubuntu1.22.04.1",
            "multipath-tools": "0.8.8-1ubuntu1.22.04.1",
            "kpartx": "0.8.8-1ubuntu1.22.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / multipath-tools

Package

Name
multipath-tools

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.4-2ubuntu3.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "kpartx-boot": "0.7.4-2ubuntu3.2",
            "multipath-tools-boot": "0.7.4-2ubuntu3.2",
            "multipath-tools": "0.7.4-2ubuntu3.2",
            "kpartx": "0.7.4-2ubuntu3.2"
        }
    ]
}

Ubuntu:20.04:LTS / multipath-tools

Package

Name
multipath-tools

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.3-1ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "kpartx-boot": "0.8.3-1ubuntu2.1",
            "multipath-tools-boot": "0.8.3-1ubuntu2.1",
            "multipath-tools": "0.8.3-1ubuntu2.1",
            "kpartx": "0.8.3-1ubuntu2.1"
        }
    ]
}