USN-5762-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5762-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5762-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5762-1
Related
Published
2022-12-05T16:03:44.739730Z
Modified
2022-12-05T16:03:44.739730Z
Summary
binutils vulnerability
Details

It was discovered that GNU binutils incorrectly handled certain COFF files. An attacker could possibly use this issue to cause a crash or execute arbitrary code.

References

Affected packages

Ubuntu:22.04:LTS / binutils

Package

Name
binutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.38-4ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "binutils-i686-kfreebsd-gnu": "2.38-4ubuntu2.1",
            "binutils-riscv64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-i686-gnu": "2.38-4ubuntu2.1",
            "binutils-common": "2.38-4ubuntu2.1",
            "binutils-powerpc64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-powerpc64le-linux-gnu": "2.38-4ubuntu2.1",
            "binutils": "2.38-4ubuntu2.1",
            "binutils-i686-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-hppa64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-for-build": "2.38-4ubuntu2.1",
            "binutils-source": "2.38-4ubuntu2.1",
            "binutils-sparc64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-x86-64-kfreebsd-gnu": "2.38-4ubuntu2.1",
            "binutils-multiarch": "2.38-4ubuntu2.1",
            "binutils-m68k-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-for-host": "2.38-4ubuntu2.1",
            "binutils-dev": "2.38-4ubuntu2.1",
            "libctf-nobfd0": "2.38-4ubuntu2.1",
            "binutils-doc": "2.38-4ubuntu2.1",
            "binutils-alpha-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-arm-linux-gnueabi": "2.38-4ubuntu2.1",
            "binutils-powerpc-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-sh4-linux-gnu": "2.38-4ubuntu2.1",
            "libbinutils": "2.38-4ubuntu2.1",
            "binutils-s390x-linux-gnu": "2.38-4ubuntu2.1",
            "libctf0": "2.38-4ubuntu2.1",
            "binutils-x86-64-linux-gnux32": "2.38-4ubuntu2.1",
            "binutils-hppa-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-arm-linux-gnueabihf": "2.38-4ubuntu2.1",
            "binutils-aarch64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-x86-64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-ia64-linux-gnu": "2.38-4ubuntu2.1",
            "binutils-multiarch-dev": "2.38-4ubuntu2.1"
        }
    ]
}

Ubuntu:20.04:LTS / binutils

Package

Name
binutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.34-6ubuntu1.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "binutils-i686-kfreebsd-gnu": "2.34-6ubuntu1.4",
            "binutils-riscv64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-i686-gnu": "2.34-6ubuntu1.4",
            "binutils-common": "2.34-6ubuntu1.4",
            "binutils-powerpc64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-powerpc64le-linux-gnu": "2.34-6ubuntu1.4",
            "binutils": "2.34-6ubuntu1.4",
            "binutils-i686-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-hppa64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-for-build": "2.34-6ubuntu1.4",
            "binutils-source": "2.34-6ubuntu1.4",
            "binutils-sparc64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-x86-64-kfreebsd-gnu": "2.34-6ubuntu1.4",
            "binutils-multiarch": "2.34-6ubuntu1.4",
            "binutils-m68k-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-for-host": "2.34-6ubuntu1.4",
            "binutils-dev": "2.34-6ubuntu1.4",
            "libctf-nobfd0": "2.34-6ubuntu1.4",
            "binutils-doc": "2.34-6ubuntu1.4",
            "binutils-alpha-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-arm-linux-gnueabi": "2.34-6ubuntu1.4",
            "binutils-powerpc-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-sh4-linux-gnu": "2.34-6ubuntu1.4",
            "libbinutils": "2.34-6ubuntu1.4",
            "binutils-s390x-linux-gnu": "2.34-6ubuntu1.4",
            "libctf0": "2.34-6ubuntu1.4",
            "binutils-x86-64-linux-gnux32": "2.34-6ubuntu1.4",
            "binutils-hppa-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-arm-linux-gnueabihf": "2.34-6ubuntu1.4",
            "binutils-aarch64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-x86-64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-ia64-linux-gnu": "2.34-6ubuntu1.4",
            "binutils-multiarch-dev": "2.34-6ubuntu1.4"
        }
    ]
}

Ubuntu:18.04:LTS / binutils

Package

Name
binutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.30-21ubuntu1~18.04.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "binutils-i686-kfreebsd-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-riscv64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-i686-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-common": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa32r6-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-powerpc64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-powerpc64le-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsel-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-i686-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mips-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-hppa64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-for-build": "2.30-21ubuntu1~18.04.8",
            "binutils-source": "2.30-21ubuntu1~18.04.8",
            "binutils-sparc64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mips64-linux-gnuabin32": "2.30-21ubuntu1~18.04.8",
            "binutils-x86-64-kfreebsd-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-multiarch": "2.30-21ubuntu1~18.04.8",
            "binutils-for-host": "2.30-21ubuntu1~18.04.8",
            "binutils-m68k-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa64r6el-linux-gnuabin32": "2.30-21ubuntu1~18.04.8",
            "binutils-dev": "2.30-21ubuntu1~18.04.8",
            "binutils-powerpc-linux-gnuspe": "2.30-21ubuntu1~18.04.8",
            "binutils-doc": "2.30-21ubuntu1~18.04.8",
            "binutils-alpha-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa64r6-linux-gnuabin32": "2.30-21ubuntu1~18.04.8",
            "binutils-arm-linux-gnueabi": "2.30-21ubuntu1~18.04.8",
            "binutils-powerpc-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-sh4-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "libbinutils": "2.30-21ubuntu1~18.04.8",
            "binutils-s390x-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa64r6-linux-gnuabi64": "2.30-21ubuntu1~18.04.8",
            "binutils-x86-64-linux-gnux32": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa32r6el-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mipsisa64r6el-linux-gnuabi64": "2.30-21ubuntu1~18.04.8",
            "binutils-hppa-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-arm-linux-gnueabihf": "2.30-21ubuntu1~18.04.8",
            "binutils-aarch64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-x86-64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-ia64-linux-gnu": "2.30-21ubuntu1~18.04.8",
            "binutils-mips64el-linux-gnuabi64": "2.30-21ubuntu1~18.04.8",
            "binutils-multiarch-dev": "2.30-21ubuntu1~18.04.8",
            "binutils-mips64el-linux-gnuabin32": "2.30-21ubuntu1~18.04.8",
            "binutils-mips64-linux-gnuabi64": "2.30-21ubuntu1~18.04.8"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / binutils

Package

Name
binutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.26.1-1ubuntu1~16.04.8+esm5

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "binutils-dev": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-powerpc-linux-gnuspe": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-powerpc64-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-powerpc64le-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-doc": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-alpha-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-arm-linux-gnueabi": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-powerpc-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-sh4-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-mipsel-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-s390x-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-mips-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-hppa64-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-sparc64-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-source": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-arm-linux-gnueabihf": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-aarch64-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-mips64-linux-gnuabi64": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-hppa-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-multiarch": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-multiarch-dev": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-m68k-linux-gnu": "2.26.1-1ubuntu1~16.04.8+esm5",
            "binutils-mips64el-linux-gnuabi64": "2.26.1-1ubuntu1~16.04.8+esm5"
        }
    ]
}