USN-5766-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5766-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5766-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5766-1
Related
Published
2022-12-07T23:29:35.029461Z
Modified
2022-12-07T23:29:35.029461Z
Summary
heimdal vulnerability
Details

It was discovered that Heimdal did not properly manage memory when normalizing Unicode. An attacker could possibly use this issue to cause a denial of service.

References

Affected packages

Ubuntu:18.04:LTS / heimdal

Package

Name
heimdal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.5.0+dfsg-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libasn1-8-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-clients": "7.5.0+dfsg-1ubuntu0.2",
            "libhdb9-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libgssapi3-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libkrb5-26-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libsl0-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libkadm5srv8-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-servers": "7.5.0+dfsg-1ubuntu0.2",
            "libhcrypto4-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libotp0-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-docs": "7.5.0+dfsg-1ubuntu0.2",
            "libwind0-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-kcm": "7.5.0+dfsg-1ubuntu0.2",
            "libkafs0-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libheimbase1-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libroken18-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-dev": "7.5.0+dfsg-1ubuntu0.2",
            "libkdc2-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-kdc": "7.5.0+dfsg-1ubuntu0.2",
            "libhx509-5-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libheimntlm0-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "libkadm5clnt7-heimdal": "7.5.0+dfsg-1ubuntu0.2",
            "heimdal-multidev": "7.5.0+dfsg-1ubuntu0.2"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / heimdal

Package

Name
heimdal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6~git20131207+dfsg-1ubuntu1.2+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libasn1-8-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-clients": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libhdb9-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libgssapi3-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libkrb5-26-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libsl0-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libkadm5srv8-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-servers": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libhcrypto4-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libotp0-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-clients-x": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-docs": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libwind0-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-kcm": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libkafs0-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libheimbase1-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libroken18-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-servers-x": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-dev": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libkdc2-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-kdc": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libhx509-5-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libheimntlm0-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "libkadm5clnt7-heimdal": "1.6~git20131207+dfsg-1ubuntu1.2+esm2",
            "heimdal-multidev": "1.6~git20131207+dfsg-1ubuntu1.2+esm2"
        }
    ]
}

Ubuntu:20.04:LTS / heimdal

Package

Name
heimdal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.7.0+dfsg-1ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libasn1-8-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-clients": "7.7.0+dfsg-1ubuntu1.2",
            "libhdb9-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libgssapi3-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libkrb5-26-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libsl0-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libkadm5srv8-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-servers": "7.7.0+dfsg-1ubuntu1.2",
            "libhcrypto4-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libotp0-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-docs": "7.7.0+dfsg-1ubuntu1.2",
            "libwind0-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-kcm": "7.7.0+dfsg-1ubuntu1.2",
            "libkafs0-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libheimbase1-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libroken18-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-dev": "7.7.0+dfsg-1ubuntu1.2",
            "libkdc2-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-kdc": "7.7.0+dfsg-1ubuntu1.2",
            "libhx509-5-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libheimntlm0-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "libkadm5clnt7-heimdal": "7.7.0+dfsg-1ubuntu1.2",
            "heimdal-multidev": "7.7.0+dfsg-1ubuntu1.2"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / heimdal

Package

Name
heimdal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libasn1-8-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-clients": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libhdb9-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libgssapi3-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libkrb5-26-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libsl0-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libkadm5srv8-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-servers": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libhcrypto4-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libotp0-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-docs": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libwind0-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-kcm": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libkafs0-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libheimbase1-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libroken18-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-dev": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libkdc2-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-kdc": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libhx509-5-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libheimntlm0-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "libkadm5clnt7-heimdal": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2",
            "heimdal-multidev": "1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2"
        }
    ]
}