USN-5776-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5776-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5776-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5776-1
Related
Published
2022-12-13T08:35:00.010676Z
Modified
2022-12-13T08:35:00.010676Z
Summary
containerd vulnerabilities
Details

It was discovered that containerd incorrectly handled memory when receiving certain faulty Exec or ExecSync commands. A remote attacker could possibly use this issue to cause a denial of service or crash containerd. (CVE-2022-23471, CVE-2022-31030)

It was discovered that containerd incorrectly set up inheritable file capabilities. An attacker could possibly use this issue to escalate privileges inside a container. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2022-24769)

It was discovered that containerd incorrectly handled access to encrypted container images when using imgcrypt library. A remote attacker could possibly use this issue to access encrypted images from other users. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2022-24778)

References

Affected packages

Ubuntu:22.04:LTS / containerd

Package

Name
containerd

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.9-0ubuntu3.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "golang-github-containerd-containerd-dev": "1.5.9-0ubuntu3.1",
            "containerd": "1.5.9-0ubuntu3.1"
        }
    ]
}

Ubuntu:18.04:LTS / containerd

Package

Name
containerd

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.9-0ubuntu1~18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "golang-github-containerd-containerd-dev": "1.5.9-0ubuntu1~18.04.2",
            "containerd": "1.5.9-0ubuntu1~18.04.2"
        }
    ]
}

Ubuntu:20.04:LTS / containerd

Package

Name
containerd

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.9-0ubuntu1~20.04.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "golang-github-containerd-containerd-dev": "1.5.9-0ubuntu1~20.04.6",
            "containerd": "1.5.9-0ubuntu1~20.04.6"
        }
    ]
}