USN-5782-3

See a problem?
Source
https://ubuntu.com/security/notices/USN-5782-3
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5782-3.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5782-3
Published
2023-01-10T06:37:50.379596Z
Modified
2023-01-10T06:37:50.379596Z
Summary
firefox regressions
Details

USN-5782-1 fixed vulnerabilities in Firefox. The update introduced several minor regressions. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Firefox was using an out-of-date libusrsctp library. An attacker could possibly use this library to perform a reentrancy issue on Firefox. (CVE-2022-46871)

Nika Layzell discovered that Firefox was not performing a check on paste received from cross-processes. An attacker could potentially exploit this to obtain sensitive information. (CVE-2022-46872)

Pete Freitag discovered that Firefox did not implement the unsafe-hashes CSP directive. An attacker who was able to inject markup into a page otherwise protected by a Content Security Policy may have been able to inject an executable script. (CVE-2022-46873)

Matthias Zoellner discovered that Firefox was not keeping the filename ending intact when using the drag-and-drop event. An attacker could possibly use this issue to add a file with a malicious extension, leading to execute arbitrary code. (CVE-2022-46874)

Hafiizh discovered that Firefox was not handling fullscreen notifications when the browser window goes into fullscreen mode. An attacker could possibly use this issue to spoof the user and obtain sensitive information. (CVE-2022-46877)

Multiple security issues were discovered in Firefox. If a user were tricked into opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service, obtain sensitive information across domains, or execute arbitrary code. (CVE-2022-46878, CVE-2022-46879)

References

Affected packages

Ubuntu:18.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
108.0.2+build1-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nl": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kn": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gl": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fy": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kk": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-km": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-or": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-az": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lt": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hy": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-eo": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sv": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-uk": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sr": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-is": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ca": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ne": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ga": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ja": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-it": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lg": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ms": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zh-hans": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ia": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ko": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hr": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mai": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nb": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-mozsymbols": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-vi": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-dev": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-he": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sw": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-el": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-oc": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-xh": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nn": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-geckodriver": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ar": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cs": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gn": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hsb": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zu": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-my": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ro": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-csb": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nso": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-af": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sk": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-szl": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-si": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cy": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fa": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cak": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sq": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-en": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-tr": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-br": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-et": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ast": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-th": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-da": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fi": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ku": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mn": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ru": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mk": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bg": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hu": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gu": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bn": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kab": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ml": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-an": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-be": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-eu": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fr": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pa": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-as": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-id": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pl": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gd": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-te": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lv": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ka": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ta": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bs": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-uz": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hi": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zh-hant": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-es": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ur": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mr": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pt": "108.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-de": "108.0.2+build1-0ubuntu0.18.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
108.0.2+build1-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nl": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kn": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gl": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fy": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kk": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-km": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-or": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-az": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lt": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hy": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-eo": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sv": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-uk": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sr": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-is": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ca": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ne": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ga": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ja": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-it": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lg": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ms": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zh-hans": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ia": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ko": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hr": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mai": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nb": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-mozsymbols": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-vi": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-dev": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-he": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sw": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-el": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-oc": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-xh": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nn": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-geckodriver": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ar": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cs": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gn": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hsb": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zu": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-my": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ro": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-csb": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nso": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-af": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sk": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-szl": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-si": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cy": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fa": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cak": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sq": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-en": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-tr": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-br": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-et": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ast": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-th": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-da": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fi": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ku": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mn": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ru": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mk": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bg": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hu": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gu": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bn": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kab": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ml": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-an": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-be": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-eu": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fr": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pa": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-as": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-id": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pl": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gd": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-te": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lv": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ka": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ta": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bs": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-uz": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hi": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zh-hant": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-es": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ur": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mr": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pt": "108.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-de": "108.0.2+build1-0ubuntu0.20.04.1"
        }
    ]
}