USN-5830-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5830-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5830-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5830-1
Related
  • CVE-2022-3643
  • CVE-2022-42896
  • CVE-2022-43945
  • CVE-2022-45934
Published
2023-01-27T18:49:52.616490Z
Modified
2023-01-27T18:49:52.616490Z
Summary
linux-azure, linux-azure-5.4, linux-raspi2 vulnerabilities
Details

It was discovered that the NFSD implementation in the Linux kernel did not properly handle some RPC messages, leading to a buffer overflow. A remote attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-43945)

Tamás Koczka discovered that the Bluetooth L2CAP handshake implementation in the Linux kernel contained multiple use-after-free vulnerabilities. A physically proximate attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-42896)

It was discovered that the Xen netback driver in the Linux kernel did not properly handle packets structured in certain ways. An attacker in a guest VM could possibly use this to cause a denial of service (host NIC availability). (CVE-2022-3643)

It was discovered that an integer overflow vulnerability existed in the Bluetooth subsystem in the Linux kernel. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2022-45934)

References

Affected packages

Ubuntu:18.04:LTS / linux-raspi2

Package

Name
linux-raspi2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1126.134

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-raspi2": "4.15.0.1126.121",
            "linux-tools-raspi2": "4.15.0.1126.121",
            "linux-modules-4.15.0-1126-raspi2": "4.15.0-1126.134",
            "linux-raspi2": "4.15.0.1126.121",
            "linux-buildinfo-4.15.0-1126-raspi2": "4.15.0-1126.134",
            "linux-headers-4.15.0-1126-raspi2": "4.15.0-1126.134",
            "linux-raspi2-tools-4.15.0-1126": "4.15.0-1126.134",
            "linux-image-4.15.0-1126-raspi2": "4.15.0-1126.134",
            "linux-raspi2-headers-4.15.0-1126": "4.15.0-1126.134",
            "linux-image-raspi2": "4.15.0.1126.121",
            "linux-tools-4.15.0-1126-raspi2": "4.15.0-1126.134"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1101.107~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-image-unsigned-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-signed-image-azure": "5.4.0.1101.74",
            "linux-modules-extra-azure": "5.4.0.1101.74",
            "linux-azure": "5.4.0.1101.74",
            "linux-azure-5.4-headers-5.4.0-1101": "5.4.0-1101.107~18.04.1",
            "linux-azure-5.4-tools-5.4.0-1101": "5.4.0-1101.107~18.04.1",
            "linux-image-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-signed-azure": "5.4.0.1101.74",
            "linux-headers-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-azure-5.4-cloud-tools-5.4.0-1101": "5.4.0-1101.107~18.04.1",
            "linux-headers-azure-edge": "5.4.0.1101.74",
            "linux-buildinfo-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-headers-azure": "5.4.0.1101.74",
            "linux-tools-azure-edge": "5.4.0.1101.74",
            "linux-modules-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-tools-azure": "5.4.0.1101.74",
            "linux-cloud-tools-azure": "5.4.0.1101.74",
            "linux-cloud-tools-azure-edge": "5.4.0.1101.74",
            "linux-azure-edge": "5.4.0.1101.74",
            "linux-image-azure": "5.4.0.1101.74",
            "linux-cloud-tools-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-signed-image-azure-edge": "5.4.0.1101.74",
            "linux-signed-azure-edge": "5.4.0.1101.74",
            "linux-tools-5.4.0-1101-azure": "5.4.0-1101.107~18.04.1",
            "linux-image-azure-edge": "5.4.0.1101.74",
            "linux-modules-extra-azure-edge": "5.4.0.1101.74"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1101.107

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-image-unsigned-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-tools-azure-lts-20.04": "5.4.0.1101.94",
            "linux-azure-tools-5.4.0-1101": "5.4.0-1101.107",
            "linux-image-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-headers-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-modules-extra-azure-lts-20.04": "5.4.0.1101.94",
            "linux-buildinfo-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-cloud-tools-azure-lts-20.04": "5.4.0.1101.94",
            "linux-image-azure-lts-20.04": "5.4.0.1101.94",
            "linux-headers-azure-lts-20.04": "5.4.0.1101.94",
            "linux-modules-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-cloud-tools-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-azure-lts-20.04": "5.4.0.1101.94",
            "linux-azure-headers-5.4.0-1101": "5.4.0-1101.107",
            "linux-tools-5.4.0-1101-azure": "5.4.0-1101.107",
            "linux-azure-cloud-tools-5.4.0-1101": "5.4.0-1101.107"
        }
    ]
}