USN-5871-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5871-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5871-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5871-1
Related
Published
2023-02-14T18:37:22.773033Z
Modified
2023-02-14T18:37:22.773033Z
Summary
git vulnerabilities
Details

It was discovered that Git incorrectly handled certain repositories. An attacker could use this issue to make Git uses its local clone optimization even when using a non-local transport. (CVE-2023-22490)

Joern Schneeweisz discovered that Git incorrectly handled certain commands. An attacker could possibly use this issue to overwrite a patch outside the working tree. (CVE-2023-23946)

References

Affected packages

Ubuntu:22.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.34.1-1ubuntu1.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-sysvinit": "1:2.34.1-1ubuntu1.8",
            "git-daemon-run": "1:2.34.1-1ubuntu1.8",
            "git-email": "1:2.34.1-1ubuntu1.8",
            "git-mediawiki": "1:2.34.1-1ubuntu1.8",
            "git": "1:2.34.1-1ubuntu1.8",
            "git-svn": "1:2.34.1-1ubuntu1.8",
            "gitk": "1:2.34.1-1ubuntu1.8",
            "git-cvs": "1:2.34.1-1ubuntu1.8",
            "gitweb": "1:2.34.1-1ubuntu1.8",
            "git-man": "1:2.34.1-1ubuntu1.8",
            "git-gui": "1:2.34.1-1ubuntu1.8",
            "git-all": "1:2.34.1-1ubuntu1.8",
            "git-doc": "1:2.34.1-1ubuntu1.8"
        }
    ]
}

Ubuntu:20.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.25.1-1ubuntu3.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.25.1-1ubuntu3.10",
            "git-email": "1:2.25.1-1ubuntu3.10",
            "git-mediawiki": "1:2.25.1-1ubuntu3.10",
            "git": "1:2.25.1-1ubuntu3.10",
            "git-el": "1:2.25.1-1ubuntu3.10",
            "git-cvs": "1:2.25.1-1ubuntu3.10",
            "git-doc": "1:2.25.1-1ubuntu3.10",
            "gitk": "1:2.25.1-1ubuntu3.10",
            "git-daemon-sysvinit": "1:2.25.1-1ubuntu3.10",
            "git-svn": "1:2.25.1-1ubuntu3.10",
            "gitweb": "1:2.25.1-1ubuntu3.10",
            "git-man": "1:2.25.1-1ubuntu3.10",
            "git-gui": "1:2.25.1-1ubuntu3.10",
            "git-all": "1:2.25.1-1ubuntu3.10"
        }
    ]
}

Ubuntu:18.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.17.1-1ubuntu0.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.17.1-1ubuntu0.16",
            "git-email": "1:2.17.1-1ubuntu0.16",
            "git-mediawiki": "1:2.17.1-1ubuntu0.16",
            "git": "1:2.17.1-1ubuntu0.16",
            "git-el": "1:2.17.1-1ubuntu0.16",
            "git-cvs": "1:2.17.1-1ubuntu0.16",
            "git-doc": "1:2.17.1-1ubuntu0.16",
            "gitk": "1:2.17.1-1ubuntu0.16",
            "git-daemon-sysvinit": "1:2.17.1-1ubuntu0.16",
            "git-svn": "1:2.17.1-1ubuntu0.16",
            "gitweb": "1:2.17.1-1ubuntu0.16",
            "git-man": "1:2.17.1-1ubuntu0.16",
            "git-gui": "1:2.17.1-1ubuntu0.16",
            "git-all": "1:2.17.1-1ubuntu0.16"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.7.4-0ubuntu1.10+esm5

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "git-core": "1:2.7.4-0ubuntu1.10+esm5",
            "git-daemon-run": "1:2.7.4-0ubuntu1.10+esm5",
            "git-email": "1:2.7.4-0ubuntu1.10+esm5",
            "git-mediawiki": "1:2.7.4-0ubuntu1.10+esm5",
            "git": "1:2.7.4-0ubuntu1.10+esm5",
            "git-el": "1:2.7.4-0ubuntu1.10+esm5",
            "git-cvs": "1:2.7.4-0ubuntu1.10+esm5",
            "git-doc": "1:2.7.4-0ubuntu1.10+esm5",
            "gitk": "1:2.7.4-0ubuntu1.10+esm5",
            "git-arch": "1:2.7.4-0ubuntu1.10+esm5",
            "git-daemon-sysvinit": "1:2.7.4-0ubuntu1.10+esm5",
            "git-svn": "1:2.7.4-0ubuntu1.10+esm5",
            "gitweb": "1:2.7.4-0ubuntu1.10+esm5",
            "git-man": "1:2.7.4-0ubuntu1.10+esm5",
            "git-gui": "1:2.7.4-0ubuntu1.10+esm5",
            "git-all": "1:2.7.4-0ubuntu1.10+esm5"
        }
    ]
}