USN-5874-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5874-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5874-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5874-1
Related
  • CVE-2022-3628
  • CVE-2022-3640
  • CVE-2022-3649
  • CVE-2022-41849
  • CVE-2022-41850
  • CVE-2022-42895
  • CVE-2023-20928
Published
2023-02-15T20:03:17.991299Z
Modified
2023-02-15T20:03:17.991299Z
Summary
linux-aws-5.4, linux-gcp, linux-gcp-5.4, linux-hwe-5.4, linux-ibm, linux-ibm-5.4, linux-oracle-5.4 vulnerabilities
Details

It was discovered that the Broadcom FullMAC USB WiFi driver in the Linux kernel did not properly perform bounds checking in some situations. A physically proximate attacker could use this to craft a malicious USB device that when inserted, could cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-3628)

It was discovered that a use-after-free vulnerability existed in the Bluetooth stack in the Linux kernel. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-3640)

Khalid Masum discovered that the NILFS2 file system implementation in the Linux kernel did not properly handle certain error conditions, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service or possibly execute arbitrary code. (CVE-2022-3649)

It was discovered that a race condition existed in the SMSC UFX USB driver implementation in the Linux kernel, leading to a use-after-free vulnerability. A physically proximate attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-41849)

It was discovered that a race condition existed in the Roccat HID driver in the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-41850)

Tamás Koczka discovered that the Bluetooth L2CAP implementation in the Linux kernel did not properly initialize memory in some situations. A physically proximate attacker could possibly use this to expose sensitive information (kernel memory). (CVE-2022-42895)

It was discovered that the binder IPC implementation in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-20928)

References

Affected packages

Ubuntu:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-139.156~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-snapdragon-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-headers-oem": "5.4.0.139.156~18.04.114",
            "linux-modules-5.4.0-139-generic-lpae": "5.4.0-139.156~18.04.1",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-cloud-tools-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-headers-5.4.0-139-generic-lpae": "5.4.0-139.156~18.04.1",
            "linux-lowlatency-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-tools-5.4.0-139-generic-lpae": "5.4.0-139.156~18.04.1",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-snapdragon-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-snapdragon-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-tools-snapdragon-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-headers-generic-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-modules-extra-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-generic-lpae-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-generic-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-5.4.0-139-generic-lpae": "5.4.0-139.156~18.04.1",
            "linux-oem": "5.4.0.139.156~18.04.114",
            "linux-buildinfo-5.4.0-139-generic-lpae": "5.4.0-139.156~18.04.1",
            "linux-headers-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-modules-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-cloud-tools-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-tools-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-hwe-5.4-cloud-tools-common": "5.4.0-139.156~18.04.1",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-buildinfo-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-headers-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-tools-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-generic-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-modules-extra-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-headers-snapdragon-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-buildinfo-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-headers-oem-osp1": "5.4.0.139.156~18.04.114",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-hwe-5.4-source-5.4.0": "5.4.0-139.156~18.04.1",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-hwe-5.4-headers-5.4.0-139": "5.4.0-139.156~18.04.1",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-headers-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-hwe-5.4-tools-5.4.0-139": "5.4.0-139.156~18.04.1",
            "linux-modules-extra-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-oem-osp1": "5.4.0.139.156~18.04.114",
            "linux-tools-oem-osp1": "5.4.0.139.156~18.04.114",
            "linux-image-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-tools-oem": "5.4.0.139.156~18.04.114",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-hwe-5.4-tools-common": "5.4.0-139.156~18.04.1",
            "linux-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-oem": "5.4.0.139.156~18.04.114",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-image-unsigned-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-image-generic-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-modules-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-image-5.4.0-139-generic": "5.4.0-139.156~18.04.1",
            "linux-image-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-oem-osp1": "5.4.0.139.156~18.04.114",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.139.156~18.04.114",
            "linux-tools-virtual-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-hwe-5.4-cloud-tools-5.4.0-139": "5.4.0-139.156~18.04.1",
            "linux-tools-snapdragon-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-tools-generic-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-unsigned-5.4.0-139-lowlatency": "5.4.0-139.156~18.04.1",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.139.156~18.04.114",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.139.156~18.04.114"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1096.104~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-aws-5.4-headers-5.4.0-1096": "5.4.0-1096.104~18.04.1",
            "linux-image-aws-edge": "5.4.0.1096.74",
            "linux-aws-5.4-tools-5.4.0-1096": "5.4.0-1096.104~18.04.1",
            "linux-headers-aws": "5.4.0.1096.74",
            "linux-aws-5.4-cloud-tools-5.4.0-1096": "5.4.0-1096.104~18.04.1",
            "linux-image-aws": "5.4.0.1096.74",
            "linux-aws": "5.4.0.1096.74",
            "linux-headers-aws-edge": "5.4.0.1096.74",
            "linux-modules-extra-aws": "5.4.0.1096.74",
            "linux-modules-extra-aws-edge": "5.4.0.1096.74",
            "linux-tools-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-tools-aws-edge": "5.4.0.1096.74",
            "linux-buildinfo-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-headers-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-modules-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-aws-edge": "5.4.0.1096.74",
            "linux-image-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-image-unsigned-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-cloud-tools-5.4.0-1096-aws": "5.4.0-1096.104~18.04.1",
            "linux-tools-aws": "5.4.0.1096.74"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1100.109~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-tools-gcp": "5.4.0.1100.76",
            "linux-headers-gcp-edge": "5.4.0.1100.76",
            "linux-gcp": "5.4.0.1100.76",
            "linux-image-unsigned-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-tools-gcp-edge": "5.4.0.1100.76",
            "linux-image-gcp-edge": "5.4.0.1100.76",
            "linux-image-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-modules-extra-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-headers-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-modules-extra-gcp": "5.4.0.1100.76",
            "linux-gcp-edge": "5.4.0.1100.76",
            "linux-modules-extra-gcp-edge": "5.4.0.1100.76",
            "linux-image-gcp": "5.4.0.1100.76",
            "linux-gcp-5.4-headers-5.4.0-1100": "5.4.0-1100.109~18.04.1",
            "linux-modules-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1",
            "linux-headers-gcp": "5.4.0.1100.76",
            "linux-gcp-5.4-tools-5.4.0-1100": "5.4.0-1100.109~18.04.1",
            "linux-tools-5.4.0-1100-gcp": "5.4.0-1100.109~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-ibm-5.4

Package

Name
linux-ibm-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1044.49~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-ibm-edge": "5.4.0.1044.55",
            "linux-modules-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-modules-extra-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-headers-ibm-edge": "5.4.0.1044.55",
            "linux-modules-extra-ibm": "5.4.0.1044.55",
            "linux-buildinfo-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-ibm-5.4-headers-5.4.0-1044": "5.4.0-1044.49~18.04.1",
            "linux-ibm-5.4-tools-common": "5.4.0-1044.49~18.04.1",
            "linux-ibm-edge": "5.4.0.1044.55",
            "linux-ibm-5.4-tools-5.4.0-1044": "5.4.0-1044.49~18.04.1",
            "linux-tools-ibm": "5.4.0.1044.55",
            "linux-modules-extra-ibm-edge": "5.4.0.1044.55",
            "linux-headers-ibm": "5.4.0.1044.55",
            "linux-ibm": "5.4.0.1044.55",
            "linux-ibm-5.4-cloud-tools-common": "5.4.0-1044.49~18.04.1",
            "linux-headers-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-image-ibm-edge": "5.4.0.1044.55",
            "linux-tools-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-image-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-image-ibm": "5.4.0.1044.55",
            "linux-image-unsigned-5.4.0-1044-ibm": "5.4.0-1044.49~18.04.1",
            "linux-ibm-5.4-source-5.4.0": "5.4.0-1044.49~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1093.102~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-oracle-5.4-tools-5.4.0-1093": "5.4.0-1093.102~18.04.1",
            "linux-modules-extra-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-tools-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-signed-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-headers-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-modules-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-signed-image-oracle": "5.4.0.1093.102~18.04.67",
            "linux-signed-oracle": "5.4.0.1093.102~18.04.67",
            "linux-oracle": "5.4.0.1093.102~18.04.67",
            "linux-tools-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-buildinfo-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-image-unsigned-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-image-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-oracle-5.4-headers-5.4.0-1093": "5.4.0-1093.102~18.04.1",
            "linux-headers-oracle": "5.4.0.1093.102~18.04.67",
            "linux-modules-extra-oracle": "5.4.0.1093.102~18.04.67",
            "linux-headers-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-signed-image-oracle-edge": "5.4.0.1093.102~18.04.67",
            "linux-modules-extra-5.4.0-1093-oracle": "5.4.0-1093.102~18.04.1",
            "linux-tools-oracle": "5.4.0.1093.102~18.04.67",
            "linux-image-oracle": "5.4.0.1093.102~18.04.67",
            "linux-oracle-edge": "5.4.0.1093.102~18.04.67"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1100.109

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-modules-extra-gcp-lts-20.04": "5.4.0.1100.102",
            "linux-gcp-tools-5.4.0-1100": "5.4.0-1100.109",
            "linux-image-gcp-lts-20.04": "5.4.0.1100.102",
            "linux-image-unsigned-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-tools-gcp-lts-20.04": "5.4.0.1100.102",
            "linux-image-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-modules-extra-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-headers-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-modules-5.4.0-1100-gcp": "5.4.0-1100.109",
            "linux-gcp-headers-5.4.0-1100": "5.4.0-1100.109",
            "linux-headers-gcp-lts-20.04": "5.4.0.1100.102",
            "linux-gcp-lts-20.04": "5.4.0.1100.102",
            "linux-tools-5.4.0-1100-gcp": "5.4.0-1100.109"
        }
    ]
}

Ubuntu:20.04:LTS / linux-ibm

Package

Name
linux-ibm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1044.49

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-ibm-lts-20.04": "5.4.0.1044.70",
            "linux-tools-ibm-lts-20.04": "5.4.0.1044.70",
            "linux-buildinfo-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-modules-extra-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-modules-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-modules-extra-ibm": "5.4.0.1044.70",
            "linux-ibm-lts-20.04": "5.4.0.1044.70",
            "linux-tools-ibm": "5.4.0.1044.70",
            "linux-ibm-tools-common": "5.4.0-1044.49",
            "linux-ibm-tools-5.4.0-1044": "5.4.0-1044.49",
            "linux-headers-ibm": "5.4.0.1044.70",
            "linux-ibm": "5.4.0.1044.70",
            "linux-modules-extra-ibm-lts-20.04": "5.4.0.1044.70",
            "linux-headers-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-image-ibm-lts-20.04": "5.4.0.1044.70",
            "linux-tools-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-image-unsigned-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-image-ibm": "5.4.0.1044.70",
            "linux-ibm-source-5.4.0": "5.4.0-1044.49",
            "linux-ibm-cloud-tools-common": "5.4.0-1044.49",
            "linux-image-5.4.0-1044-ibm": "5.4.0-1044.49",
            "linux-ibm-headers-5.4.0-1044": "5.4.0-1044.49"
        }
    ]
}