USN-5920-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5920-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5920-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5920-1
Related
  • CVE-2022-3521
  • CVE-2022-3545
  • CVE-2022-3628
  • CVE-2022-3640
  • CVE-2022-42328
  • CVE-2022-42329
  • CVE-2022-42895
  • CVE-2022-4378
  • CVE-2023-0461
Published
2023-03-03T16:39:13.116812Z
Modified
2023-03-03T16:39:13.116812Z
Summary
linux, linux-aws, linux-dell300x, linux-gcp-4.15, linux-oracle vulnerabilities
Details

It was discovered that the Upper Level Protocol (ULP) subsystem in the Linux kernel did not properly handle sockets entering the LISTEN state in certain protocols, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-0461)

Kyle Zeng discovered that the sysctl implementation in the Linux kernel contained a stack-based buffer overflow. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2022-4378)

It was discovered that a race condition existed in the Kernel Connection Multiplexor (KCM) socket implementation in the Linux kernel when releasing sockets in certain situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2022-3521)

It was discovered that the Netronome Ethernet driver in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-3545)

It was discovered that the Broadcom FullMAC USB WiFi driver in the Linux kernel did not properly perform bounds checking in some situations. A physically proximate attacker could use this to craft a malicious USB device that when inserted, could cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-3628)

It was discovered that a use-after-free vulnerability existed in the Bluetooth stack in the Linux kernel. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-3640)

It was discovered that a race condition existed in the Xen network backend driver in the Linux kernel when handling dropped packets in certain circumstances. An attacker could use this to cause a denial of service (kernel deadlock). (CVE-2022-42328, CVE-2022-42329)

Tamás Koczka discovered that the Bluetooth L2CAP implementation in the Linux kernel did not properly initialize memory in some situations. A physically proximate attacker could possibly use this to expose sensitive information (kernel memory). (CVE-2022-42895)

References

Affected packages

Ubuntu:18.04:LTS / linux-dell300x

Package

Name
linux-dell300x

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1061.66

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-dell300x": "4.15.0.1061.60",
            "linux-dell300x-tools-4.15.0-1061": "4.15.0-1061.66",
            "linux-dell300x": "4.15.0.1061.60",
            "linux-buildinfo-4.15.0-1061-dell300x": "4.15.0-1061.66",
            "linux-tools-4.15.0-1061-dell300x": "4.15.0-1061.66",
            "linux-modules-4.15.0-1061-dell300x": "4.15.0-1061.66",
            "linux-dell300x-headers-4.15.0-1061": "4.15.0-1061.66",
            "linux-image-dell300x": "4.15.0.1061.60",
            "linux-image-4.15.0-1061-dell300x": "4.15.0-1061.66",
            "linux-headers-dell300x": "4.15.0.1061.60",
            "linux-image-unsigned-4.15.0-1061-dell300x": "4.15.0-1061.66",
            "linux-headers-4.15.0-1061-dell300x": "4.15.0-1061.66"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-4.15

Package

Name
linux-gcp-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1146.162

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-gcp-lts-18.04": "4.15.0.1146.160",
            "linux-image-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-modules-extra-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-headers-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-image-unsigned-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-modules-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-headers-gcp-lts-18.04": "4.15.0.1146.160",
            "linux-image-gcp-lts-18.04": "4.15.0.1146.160",
            "linux-tools-gcp-lts-18.04": "4.15.0.1146.160",
            "linux-gcp-4.15-headers-4.15.0-1146": "4.15.0-1146.162",
            "linux-gcp-lts-18.04": "4.15.0.1146.160",
            "linux-tools-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-buildinfo-4.15.0-1146-gcp": "4.15.0-1146.162",
            "linux-gcp-4.15-tools-4.15.0-1146": "4.15.0-1146.162"
        }
    ]
}

Ubuntu:18.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-206.217

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-4.15.0-206-generic-lpae": "4.15.0-206.217",
            "linux-image-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-cloud-tools-4.15.0-206": "4.15.0-206.217",
            "linux-cloud-tools-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-signed-image-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-signed-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-cloud-tools-virtual": "4.15.0.206.189",
            "linux-cloud-tools-lowlatency": "4.15.0.206.189",
            "linux-tools-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-tools-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-cloud-tools-generic-hwe-16.04": "4.15.0.206.189",
            "linux-tools-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-cloud-tools-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-cloud-tools-virtual-hwe-16.04": "4.15.0.206.189",
            "linux-modules-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-signed-image-lowlatency": "4.15.0.206.189",
            "linux-tools-virtual": "4.15.0.206.189",
            "linux-source": "4.15.0.206.189",
            "linux-image-extra-virtual": "4.15.0.206.189",
            "linux-tools-4.15.0-206-generic-lpae": "4.15.0-206.217",
            "linux-tools-generic-lpae-hwe-16.04-edge": "4.15.0.206.189",
            "linux-cloud-tools-generic": "4.15.0.206.189",
            "linux-headers-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-buildinfo-4.15.0-206-generic": "4.15.0-206.217",
            "linux-tools-generic": "4.15.0.206.189",
            "linux-image-virtual": "4.15.0.206.189",
            "linux-tools-generic-lpae-hwe-16.04": "4.15.0.206.189",
            "linux-image-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-virtual": "4.15.0.206.189",
            "linux-modules-4.15.0-206-generic": "4.15.0-206.217",
            "linux-signed-image-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-generic-hwe-16.04": "4.15.0.206.189",
            "linux-modules-extra-4.15.0-206-generic": "4.15.0-206.217",
            "linux-generic-lpae": "4.15.0.206.189",
            "linux-image-4.15.0-206-generic": "4.15.0-206.217",
            "linux-headers-4.15.0-206": "4.15.0-206.217",
            "linux-cloud-tools-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-crashdump": "4.15.0.206.189",
            "linux-generic-lpae-hwe-16.04-edge": "4.15.0.206.189",
            "linux-headers-4.15.0-206-generic-lpae": "4.15.0-206.217",
            "linux-image-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-generic": "4.15.0.206.189",
            "linux-tools-virtual-hwe-16.04": "4.15.0.206.189",
            "linux-signed-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-image-unsigned-4.15.0-206-generic": "4.15.0-206.217",
            "linux-signed-image-generic-hwe-16.04": "4.15.0.206.189",
            "linux-headers-4.15.0-206-generic": "4.15.0-206.217",
            "linux-headers-generic-lpae": "4.15.0.206.189",
            "linux-image-generic-lpae": "4.15.0.206.189",
            "linux-cloud-tools-4.15.0-206-generic": "4.15.0-206.217",
            "linux-signed-image-generic": "4.15.0.206.189",
            "linux-tools-lowlatency": "4.15.0.206.189",
            "linux-image-4.15.0-206-generic-lpae": "4.15.0-206.217",
            "linux-source-4.15.0": "4.15.0-206.217",
            "linux-cloud-tools-common": "4.15.0-206.217",
            "linux-signed-generic-hwe-16.04": "4.15.0.206.189",
            "linux-signed-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-tools-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-libc-dev": "4.15.0-206.217",
            "linux-headers-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-headers-virtual-hwe-16.04": "4.15.0.206.189",
            "linux-doc": "4.15.0-206.217",
            "linux-image-extra-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-tools-generic-hwe-16.04": "4.15.0.206.189",
            "linux-tools-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-headers-generic": "4.15.0.206.189",
            "linux-image-generic-lpae-hwe-16.04": "4.15.0.206.189",
            "linux-headers-lowlatency": "4.15.0.206.189",
            "linux-headers-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-image-lowlatency": "4.15.0.206.189",
            "linux-headers-virtual": "4.15.0.206.189",
            "linux-cloud-tools-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-headers-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-tools-host": "4.15.0-206.217",
            "linux-generic-lpae-hwe-16.04": "4.15.0.206.189",
            "linux-headers-generic-lpae-hwe-16.04-edge": "4.15.0.206.189",
            "linux-headers-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-image-unsigned-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-signed-lowlatency": "4.15.0.206.189",
            "linux-tools-generic-lpae": "4.15.0.206.189",
            "linux-virtual-hwe-16.04": "4.15.0.206.189",
            "linux-signed-image-lowlatency-hwe-16.04": "4.15.0.206.189",
            "linux-headers-generic-lpae-hwe-16.04": "4.15.0.206.189",
            "linux-tools-4.15.0-206": "4.15.0-206.217",
            "linux-image-extra-virtual-hwe-16.04": "4.15.0.206.189",
            "linux-buildinfo-4.15.0-206-lowlatency": "4.15.0-206.217",
            "linux-buildinfo-4.15.0-206-generic-lpae": "4.15.0-206.217",
            "linux-signed-generic": "4.15.0.206.189",
            "linux-headers-generic-hwe-16.04": "4.15.0.206.189",
            "linux-image-generic-lpae-hwe-16.04-edge": "4.15.0.206.189",
            "linux-tools-common": "4.15.0-206.217",
            "linux-cloud-tools-virtual-hwe-16.04-edge": "4.15.0.206.189",
            "linux-lowlatency": "4.15.0.206.189",
            "linux-image-lowlatency-hwe-16.04-edge": "4.15.0.206.189",
            "linux-image-generic": "4.15.0.206.189",
            "linux-tools-4.15.0-206-generic": "4.15.0-206.217",
            "linux-image-generic-hwe-16.04-edge": "4.15.0.206.189",
            "linux-image-generic-hwe-16.04": "4.15.0.206.189",
            "linux-image-virtual-hwe-16.04": "4.15.0.206.189"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1115.126

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oracle-lts-18.04": "4.15.0.1115.120",
            "linux-image-unsigned-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-oracle-headers-4.15.0-1115": "4.15.0-1115.126",
            "linux-headers-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-tools-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-image-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-signed-image-oracle-lts-18.04": "4.15.0.1115.120",
            "linux-modules-extra-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-oracle-tools-4.15.0-1115": "4.15.0-1115.126",
            "linux-modules-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-oracle-lts-18.04": "4.15.0.1115.120",
            "linux-tools-oracle-lts-18.04": "4.15.0.1115.120",
            "linux-buildinfo-4.15.0-1115-oracle": "4.15.0-1115.126",
            "linux-signed-oracle-lts-18.04": "4.15.0.1115.120",
            "linux-headers-oracle-lts-18.04": "4.15.0.1115.120"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1151.164

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-image-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-modules-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-modules-extra-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-headers-aws-lts-18.04": "4.15.0.1151.149",
            "linux-aws-lts-18.04": "4.15.0.1151.149",
            "linux-aws-tools-4.15.0-1151": "4.15.0-1151.164",
            "linux-cloud-tools-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-tools-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-modules-extra-aws-lts-18.04": "4.15.0.1151.149",
            "linux-tools-aws-lts-18.04": "4.15.0.1151.149",
            "linux-aws-cloud-tools-4.15.0-1151": "4.15.0-1151.164",
            "linux-buildinfo-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-aws-headers-4.15.0-1151": "4.15.0-1151.164",
            "linux-image-unsigned-4.15.0-1151-aws": "4.15.0-1151.164",
            "linux-image-aws-lts-18.04": "4.15.0.1151.149"
        }
    ]
}