USN-5930-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5930-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5930-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5930-1
Related
Published
2023-03-07T12:12:34.576574Z
Modified
2023-03-07T12:12:34.576574Z
Summary
python3.7 vulnerability
Details

It was discovered that Python incorrectly handled certain inputs. If a user or an automated system were tricked into running a specially crafted input, a remote attacker could possibly use this issue to execute arbitrary code. (CVE-2022-37454)

References

Affected packages

Ubuntu:Pro:18.04:LTS / python3.7

Package

Name
python3.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.7.5-2ubuntu1~18.04.2+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "idle-python3.7": "3.7.5-2ubuntu1~18.04.2+esm2",
            "libpython3.7-stdlib": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7-examples": "3.7.5-2ubuntu1~18.04.2+esm2",
            "libpython3.7-testsuite": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7-dev": "3.7.5-2ubuntu1~18.04.2+esm2",
            "libpython3.7-minimal": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7-venv": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7-minimal": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7": "3.7.5-2ubuntu1~18.04.2+esm2",
            "python3.7-doc": "3.7.5-2ubuntu1~18.04.2+esm2",
            "libpython3.7": "3.7.5-2ubuntu1~18.04.2+esm2",
            "libpython3.7-dev": "3.7.5-2ubuntu1~18.04.2+esm2"
        }
    ]
}