USN-5961-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5961-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5961-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5961-1
Related
Published
2023-03-16T14:18:37.293881Z
Modified
2023-03-16T14:18:37.293881Z
Summary
abcm2ps vulnerabilities
Details

It was discovered that abcm2ps incorrectly handled memory when parsing specially crafted ABC files. An attacker could use this issue to cause abcm2ps to crash, leading to a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 ESM and Ubuntu 18.04 LTS. (CVE-2018-10753, CVE-2018-10771, CVE-2019-1010069)

Chiba of Topsec Alpha Lab discovered that abcm2ps incorrectly handled memory when parsing specially crafted ABC files. An attacker could use this issue to cause abcm2ps to crash, leading to a denial of service. (CVE-2021-32434, CVE-2021-32435, CVE-2021-32436)

References

Affected packages

Ubuntu:Pro:22.04:LTS / abcm2ps

Package

Name
abcm2ps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.14.11-0.1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "abcm2ps": "8.14.11-0.1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:18.04:LTS / abcm2ps

Package

Name
abcm2ps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.8.9-1+deb9u1build0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "abcm2ps": "7.8.9-1+deb9u1build0.18.04.1"
        }
    ]
}

Ubuntu:Pro:20.04:LTS / abcm2ps

Package

Name
abcm2ps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.14.6-0.1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "abcm2ps": "8.14.6-0.1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / abcm2ps

Package

Name
abcm2ps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.8.9-1ubuntu0.16.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "abcm2ps": "7.8.9-1ubuntu0.16.04.1~esm1"
        }
    ]
}