USN-6022-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6022-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6022-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6022-1
Related
Published
2023-04-14T17:20:51.713534Z
Modified
2023-04-14T17:20:51.713534Z
Summary
kamailio vulnerabilities
Details

It was discovered that Kamailio did not properly sanitize SIP messages under certain circumstances. An attacker could use this vulnerability to cause a denial of service or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 ESM and 18.04 ESM. (CVE-2018-16657)

It was discovered that Kamailio did not properly validate INVITE requests under certain circumstances. An attacker could use this vulnerability to cause a denial of service or possibly execute arbitrary code. (CVE-2020-27507)

References

Affected packages

Ubuntu:Pro:18.04:LTS / kamailio

Package

Name
kamailio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.2-1ubuntu2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "kamailio-snmpstats-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-postgres-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-xml-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-kazoo-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-sctp-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-sqlite-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-mysql-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-berkeley-bin": "5.1.2-1ubuntu2+esm1",
            "kamailio": "5.1.2-1ubuntu2+esm1",
            "kamailio-memcached-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-ims-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-cpl-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-xmpp-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-unixodbc-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-extra-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-lua-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-cnxcc-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-systemd-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-radius-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-berkeley-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-json-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-presence-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-tls-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-phonenum-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-geoip-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-python-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-geoip2-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-redis-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-carrierroute-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-ldap-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-autheph-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-outbound-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-perl-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-erlang-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-rabbitmq-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-mongodb-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-utils-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-websocket-modules": "5.1.2-1ubuntu2+esm1",
            "kamailio-mono-modules": "5.1.2-1ubuntu2+esm1"
        }
    ]
}

Ubuntu:Pro:20.04:LTS / kamailio

Package

Name
kamailio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.2-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "kamailio-mono-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-snmpstats-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-postgres-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-xml-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-kazoo-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-sctp-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-sqlite-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-mysql-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-berkeley-bin": "5.3.2-1ubuntu0.1~esm1",
            "kamailio": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-memcached-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-ims-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-cpl-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-xmpp-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-unixodbc-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-extra-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-json-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-cnxcc-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-systemd-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-lua-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-berkeley-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-radius-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-presence-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-tls-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-phonenum-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-geoip-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-geoip2-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-redis-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-ldap-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-autheph-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-outbound-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-perl-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-python3-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-rabbitmq-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-mongodb-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-utils-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-websocket-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-ruby-modules": "5.3.2-1ubuntu0.1~esm1",
            "kamailio-erlang-modules": "5.3.2-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / kamailio

Package

Name
kamailio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.3.4-1.1ubuntu2.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "kamailio-snmpstats-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-postgres-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-xml-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-kazoo-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-sctp-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-berkeley-bin": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-mysql-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-java-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-sqlite-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-dnssec-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-memcached-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-cpl-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-ims-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-xmpp-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-purple-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-extra-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-unixodbc-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-lua-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-cnxcc-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-radius-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-json-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-berkeley-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-presence-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-tls-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-geoip-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-python-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-redis-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-carrierroute-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-ldap-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-erlang-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-outbound-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-perl-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-autheph-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-mono-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-utils-modules": "4.3.4-1.1ubuntu2.1+esm1",
            "kamailio-websocket-modules": "4.3.4-1.1ubuntu2.1+esm1"
        }
    ]
}