USN-6025-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6025-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6025-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6025-1
Related
  • CVE-2022-4129
  • CVE-2022-47929
  • CVE-2022-4842
  • CVE-2023-0386
  • CVE-2023-0394
  • CVE-2023-1073
  • CVE-2023-1074
  • CVE-2023-1281
  • CVE-2023-1652
  • CVE-2023-26545
Published
2023-04-19T02:27:48.133523Z
Modified
2023-04-19T02:27:48.133523Z
Summary
linux, linux-aws, linux-aws-5.15, linux-azure, linux-azure-5.15, linux-azure-fde, linux-gcp, linux-gcp-5.15, linux-gke, linux-gke-5.15, linux-gkeop, linux-ibm, linux-kvm, linux-lowlatency, linux-lowlatency-hwe-5.15, linux-oracle, linux-oracle-5.15, linux-raspi vulnerabilities
Details

It was discovered that the Traffic-Control Index (TCINDEX) implementation in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-1281)

It was discovered that the OverlayFS implementation in the Linux kernel did not properly handle copy up operation in some conditions. A local attacker could possibly use this to gain elevated privileges. (CVE-2023-0386)

Haowei Yan discovered that a race condition existed in the Layer 2 Tunneling Protocol (L2TP) implementation in the Linux kernel. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2022-4129)

It was discovered that the network queuing discipline implementation in the Linux kernel contained a null pointer dereference in some situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2022-47929)

It was discovered that the NTFS file system implementation in the Linux kernel contained a null pointer dereference in some situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2022-4842)

Kyle Zeng discovered that the IPv6 implementation in the Linux kernel contained a NULL pointer dereference vulnerability in certain situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-0394)

It was discovered that the Human Interface Device (HID) support driver in the Linux kernel contained a type confusion vulnerability in some situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-1073)

It was discovered that a memory leak existed in the SCTP protocol implementation in the Linux kernel. A local attacker could use this to cause a denial of service (memory exhaustion). (CVE-2023-1074)

It was discovered that the NFS implementation in the Linux kernel did not properly handle pending tasks in some situations. A local attacker could use this to cause a denial of service (system crash) or expose sensitive information (kernel memory). (CVE-2023-1652)

Lianhui Tang discovered that the MPLS implementation in the Linux kernel did not properly handle certain sysctl allocation failure conditions, leading to a double-free vulnerability. An attacker could use this to cause a denial of service or possibly execute arbitrary code. (CVE-2023-26545)

References

Affected packages

Ubuntu:22.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1036.43

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-modules-extra-azure": "5.15.0.1036.32",
            "linux-modules-extra-azure-lts-22.04": "5.15.0.1036.32",
            "linux-headers-azure-lts-22.04": "5.15.0.1036.32",
            "linux-azure": "5.15.0.1036.32",
            "linux-tools-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-azure-tools-5.15.0-1036": "5.15.0-1036.43",
            "linux-modules-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-azure-headers-5.15.0-1036": "5.15.0-1036.43",
            "linux-azure-cloud-tools-5.15.0-1036": "5.15.0-1036.43",
            "linux-tools-azure-lts-22.04": "5.15.0.1036.32",
            "linux-buildinfo-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-headers-azure": "5.15.0.1036.32",
            "linux-tools-azure": "5.15.0.1036.32",
            "linux-cloud-tools-azure": "5.15.0.1036.32",
            "linux-image-azure-lts-22.04": "5.15.0.1036.32",
            "linux-azure-lts-22.04": "5.15.0.1036.32",
            "linux-modules-extra-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-image-azure": "5.15.0.1036.32",
            "linux-cloud-tools-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-cloud-tools-azure-lts-22.04": "5.15.0.1036.32",
            "linux-image-5.15.0-1036-azure": "5.15.0-1036.43",
            "linux-headers-5.15.0-1036-azure": "5.15.0-1036.43"
        }
    ]
}

Ubuntu:22.04:LTS / linux-azure-fde

Package

Name
linux-azure-fde

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1036.43.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-azure-fde": "5.15.0.1036.43.13",
            "linux-modules-extra-azure-fde": "5.15.0.1036.43.13",
            "linux-image-5.15.0-1036-azure-fde": "5.15.0-1036.43.1",
            "linux-image-unsigned-5.15.0-1036-azure-fde": "5.15.0-1036.43.1",
            "linux-image-azure-fde": "5.15.0.1036.43.13",
            "linux-azure-fde": "5.15.0.1036.43.13",
            "linux-tools-azure-fde": "5.15.0.1036.43.13",
            "linux-cloud-tools-azure-fde": "5.15.0.1036.43.13"
        }
    ]
}

Ubuntu:22.04:LTS / linux-gkeop

Package

Name
linux-gkeop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1018.23

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-gkeop": "5.15.0.1018.17",
            "linux-headers-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-cloud-tools-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-headers-gkeop-5.15": "5.15.0.1018.17",
            "linux-cloud-tools-gkeop": "5.15.0.1018.17",
            "linux-gkeop": "5.15.0.1018.17",
            "linux-tools-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-tools-gkeop": "5.15.0.1018.17",
            "linux-image-unsigned-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-modules-extra-gkeop": "5.15.0.1018.17",
            "linux-modules-extra-gkeop-5.15": "5.15.0.1018.17",
            "linux-tools-gkeop-5.15": "5.15.0.1018.17",
            "linux-image-gkeop": "5.15.0.1018.17",
            "linux-image-gkeop-5.15": "5.15.0.1018.17",
            "linux-image-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-gkeop-tools-5.15.0-1018": "5.15.0-1018.23",
            "linux-modules-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-gkeop-5.15": "5.15.0.1018.17",
            "linux-buildinfo-5.15.0-1018-gkeop": "5.15.0-1018.23",
            "linux-gkeop-headers-5.15.0-1018": "5.15.0-1018.23",
            "linux-cloud-tools-gkeop-5.15": "5.15.0.1018.17",
            "linux-gkeop-cloud-tools-5.15.0-1018": "5.15.0-1018.23",
            "linux-modules-extra-5.15.0-1018-gkeop": "5.15.0-1018.23"
        }
    ]
}

Ubuntu:22.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-70.77

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.15.0-70-generic-lpae": "5.15.0-70.77",
            "linux-cloud-tools-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-image-generic-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-generic-hwe-20.04": "5.15.0.70.68",
            "linux-image-generic-lpae-hwe-20.04": "5.15.0.70.68",
            "linux-cloud-tools-virtual": "5.15.0.70.68",
            "linux-headers-generic-hwe-20.04": "5.15.0.70.68",
            "linux-modules-5.15.0-70-generic-lpae": "5.15.0-70.77",
            "linux-image-generic-hwe-20.04": "5.15.0.70.68",
            "linux-image-generic-64k-hwe-20.04": "5.15.0.70.68",
            "linux-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-headers-generic-lpae-hwe-20.04": "5.15.0.70.68",
            "linux-tools-virtual": "5.15.0.70.68",
            "linux-tools-generic-hwe-20.04-edge": "5.15.0.70.68",
            "linux-source": "5.15.0.70.68",
            "linux-image-5.15.0-70-generic-lpae": "5.15.0-70.77",
            "linux-image-extra-virtual": "5.15.0.70.68",
            "linux-cloud-tools-generic": "5.15.0.70.68",
            "linux-image-virtual": "5.15.0.70.68",
            "linux-headers-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-generic": "5.15.0.70.68",
            "linux-generic-lpae": "5.15.0.70.68",
            "linux-modules-5.15.0-70-generic": "5.15.0-70.77",
            "linux-generic-lpae-hwe-20.04-edge": "5.15.0.70.68",
            "linux-virtual": "5.15.0.70.68",
            "linux-image-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-image-unsigned-5.15.0-70-generic": "5.15.0-70.77",
            "linux-tools-generic-64k": "5.15.0.70.68",
            "linux-tools-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-headers-5.15.0-70": "5.15.0-70.77",
            "linux-headers-generic-hwe-20.04-edge": "5.15.0.70.68",
            "linux-generic-hwe-20.04": "5.15.0.70.68",
            "linux-generic": "5.15.0.70.68",
            "linux-buildinfo-5.15.0-70-generic": "5.15.0-70.77",
            "linux-image-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-image-5.15.0-70-generic": "5.15.0-70.77",
            "linux-crashdump": "5.15.0.70.68",
            "linux-generic-hwe-20.04-edge": "5.15.0.70.68",
            "linux-generic-64k": "5.15.0.70.68",
            "linux-image-extra-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-tools-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-tools-generic-lpae-hwe-20.04-edge": "5.15.0.70.68",
            "linux-headers-generic-lpae": "5.15.0.70.68",
            "linux-cloud-tools-5.15.0-70": "5.15.0-70.77",
            "linux-image-generic-lpae": "5.15.0.70.68",
            "linux-generic-64k-hwe-20.04": "5.15.0.70.68",
            "linux-modules-extra-5.15.0-70-generic": "5.15.0-70.77",
            "linux-headers-5.15.0-70-generic-lpae": "5.15.0-70.77",
            "linux-headers-generic-64k": "5.15.0.70.68",
            "linux-cloud-tools-generic-hwe-20.04-edge": "5.15.0.70.68",
            "linux-libc-dev": "5.15.0-70.77",
            "linux-image-oem-20.04": "5.15.0.70.68",
            "linux-generic-64k-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-generic-lpae-hwe-20.04": "5.15.0.70.68",
            "linux-doc": "5.15.0-70.77",
            "linux-cloud-tools-common": "5.15.0-70.77",
            "linux-generic-lpae-hwe-20.04": "5.15.0.70.68",
            "linux-cloud-tools-generic-hwe-20.04": "5.15.0.70.68",
            "linux-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-image-generic-64k": "5.15.0.70.68",
            "linux-tools-oem-20.04": "5.15.0.70.68",
            "linux-buildinfo-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-tools-5.15.0-70-generic-lpae": "5.15.0-70.77",
            "linux-headers-generic": "5.15.0.70.68",
            "linux-source-5.15.0": "5.15.0-70.77",
            "linux-tools-generic-64k-hwe-20.04-edge": "5.15.0.70.68",
            "linux-headers-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-tools-5.15.0-70-generic": "5.15.0-70.77",
            "linux-image-extra-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-5.15.0-70": "5.15.0-70.77",
            "linux-headers-virtual": "5.15.0.70.68",
            "linux-image-generic-64k-hwe-20.04-edge": "5.15.0.70.68",
            "linux-modules-iwlwifi-generic": "5.15.0.70.68",
            "linux-tools-virtual-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-host": "5.15.0-70.77",
            "linux-cloud-tools-5.15.0-70-generic": "5.15.0-70.77",
            "linux-image-generic-lpae-hwe-20.04-edge": "5.15.0.70.68",
            "linux-cloud-tools-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-image-unsigned-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-headers-generic-64k-hwe-20.04": "5.15.0.70.68",
            "linux-headers-generic-64k-hwe-20.04-edge": "5.15.0.70.68",
            "linux-tools-generic-lpae": "5.15.0.70.68",
            "linux-headers-generic-lpae-hwe-20.04-edge": "5.15.0.70.68",
            "linux-modules-iwlwifi-5.15.0-70-generic": "5.15.0-70.77",
            "linux-modules-5.15.0-70-generic-64k": "5.15.0-70.77",
            "linux-image-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-headers-virtual-hwe-20.04": "5.15.0.70.68",
            "linux-oem-20.04": "5.15.0.70.68",
            "linux-headers-oem-20.04": "5.15.0.70.68",
            "linux-tools-generic-64k-hwe-20.04": "5.15.0.70.68",
            "linux-tools-common": "5.15.0-70.77",
            "linux-image-generic": "5.15.0.70.68",
            "linux-headers-5.15.0-70-generic": "5.15.0-70.77"
        }
    ]
}

Ubuntu:22.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1031.36

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-kvm": "5.15.0.1031.27",
            "linux-buildinfo-5.15.0-1031-kvm": "5.15.0-1031.36",
            "linux-kvm": "5.15.0.1031.27",
            "linux-tools-kvm": "5.15.0.1031.27",
            "linux-image-5.15.0-1031-kvm": "5.15.0-1031.36",
            "linux-tools-5.15.0-1031-kvm": "5.15.0-1031.36",
            "linux-kvm-headers-5.15.0-1031": "5.15.0-1031.36",
            "linux-modules-5.15.0-1031-kvm": "5.15.0-1031.36",
            "linux-headers-5.15.0-1031-kvm": "5.15.0-1031.36",
            "linux-kvm-tools-5.15.0-1031": "5.15.0-1031.36",
            "linux-image-kvm": "5.15.0.1031.27",
            "linux-image-unsigned-5.15.0-1031-kvm": "5.15.0-1031.36"
        }
    ]
}

Ubuntu:22.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1034.38

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-aws-headers-5.15.0-1034": "5.15.0-1034.38",
            "linux-modules-extra-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-image-unsigned-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-cloud-tools-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-image-aws-lts-22.04": "5.15.0.1034.33",
            "linux-modules-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-aws-tools-5.15.0-1034": "5.15.0-1034.38",
            "linux-aws-lts-22.04": "5.15.0.1034.33",
            "linux-headers-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-aws-cloud-tools-5.15.0-1034": "5.15.0-1034.38",
            "linux-image-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-modules-extra-aws-lts-22.04": "5.15.0.1034.33",
            "linux-buildinfo-5.15.0-1034-aws": "5.15.0-1034.38",
            "linux-headers-aws-lts-22.04": "5.15.0.1034.33",
            "linux-tools-aws-lts-22.04": "5.15.0.1034.33",
            "linux-tools-5.15.0-1034-aws": "5.15.0-1034.38"
        }
    ]
}

Ubuntu:22.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1027.29

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-tools-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-modules-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-headers-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-headers-raspi-nolpae": "5.15.0.1027.24",
            "linux-headers-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-tools-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-tools-raspi": "5.15.0.1027.24",
            "linux-modules-extra-raspi-nolpae": "5.15.0.1027.24",
            "linux-headers-raspi": "5.15.0.1027.24",
            "linux-raspi-tools-5.15.0-1027": "5.15.0-1027.29",
            "linux-raspi-nolpae": "5.15.0.1027.24",
            "linux-buildinfo-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-buildinfo-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-modules-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-image-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-raspi": "5.15.0.1027.24",
            "linux-image-5.15.0-1027-raspi": "5.15.0-1027.29",
            "linux-image-raspi-nolpae": "5.15.0.1027.24",
            "linux-modules-extra-5.15.0-1027-raspi-nolpae": "5.15.0-1027.29",
            "linux-image-raspi": "5.15.0.1027.24",
            "linux-tools-raspi-nolpae": "5.15.0.1027.24",
            "linux-modules-extra-raspi": "5.15.0.1027.24",
            "linux-raspi-headers-5.15.0-1027": "5.15.0-1027.29"
        }
    ]
}

Ubuntu:22.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1033.39

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oracle": "5.15.0.1033.28",
            "linux-image-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-headers-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-oracle-headers-5.15.0-1033": "5.15.0-1033.39",
            "linux-modules-extra-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-modules-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-headers-oracle": "5.15.0.1033.28",
            "linux-buildinfo-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-oracle-tools-5.15.0-1033": "5.15.0-1033.39",
            "linux-image-unsigned-5.15.0-1033-oracle": "5.15.0-1033.39",
            "linux-tools-oracle": "5.15.0.1033.28",
            "linux-image-oracle": "5.15.0.1033.28",
            "linux-tools-5.15.0-1033-oracle": "5.15.0-1033.39"
        }
    ]
}

Ubuntu:22.04:LTS / linux-lowlatency

Package

Name
linux-lowlatency

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-70.77

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-lowlatency": "5.15.0.70.75",
            "linux-headers-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.75",
            "linux-headers-lowlatency-hwe-20.04-edge": "5.15.0.70.75",
            "linux-tools-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.75",
            "linux-tools-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-headers-lowlatency-hwe-20.04": "5.15.0.70.75",
            "linux-cloud-tools-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-image-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-cloud-tools-lowlatency": "5.15.0.70.75",
            "linux-image-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.75",
            "linux-tools-lowlatency-64k": "5.15.0.70.75",
            "linux-buildinfo-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.75",
            "linux-lowlatency-headers-5.15.0-70": "5.15.0-70.77",
            "linux-headers-lowlatency-64k-hwe-20.04": "5.15.0.70.75",
            "linux-image-lowlatency-hwe-20.04-edge": "5.15.0.70.75",
            "linux-headers-lowlatency": "5.15.0.70.75",
            "linux-tools-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-lowlatency-64k-hwe-20.04": "5.15.0.70.75",
            "linux-image-lowlatency-hwe-20.04": "5.15.0.70.75",
            "linux-image-lowlatency": "5.15.0.70.75",
            "linux-tools-lowlatency-hwe-20.04-edge": "5.15.0.70.75",
            "linux-headers-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-image-unsigned-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-buildinfo-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-image-unsigned-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-lowlatency-tools-common": "5.15.0-70.77",
            "linux-headers-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-modules-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-lowlatency-tools-5.15.0-70": "5.15.0-70.77",
            "linux-tools-lowlatency-64k-hwe-20.04": "5.15.0.70.75",
            "linux-image-lowlatency-64k-hwe-20.04": "5.15.0.70.75",
            "linux-lowlatency-tools-host": "5.15.0-70.77",
            "linux-lowlatency-cloud-tools-common": "5.15.0-70.77",
            "linux-tools-lowlatency-hwe-20.04": "5.15.0.70.75",
            "linux-headers-lowlatency-64k": "5.15.0.70.75",
            "linux-lowlatency-cloud-tools-5.15.0-70": "5.15.0-70.77",
            "linux-lowlatency-64k": "5.15.0.70.75",
            "linux-modules-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-lowlatency-hwe-20.04": "5.15.0.70.75",
            "linux-modules-iwlwifi-5.15.0-70-lowlatency": "5.15.0-70.77",
            "linux-cloud-tools-lowlatency-hwe-20.04": "5.15.0.70.75",
            "linux-image-5.15.0-70-lowlatency-64k": "5.15.0-70.77",
            "linux-image-lowlatency-64k": "5.15.0.70.75",
            "linux-cloud-tools-lowlatency-hwe-20.04-edge": "5.15.0.70.75",
            "linux-lowlatency": "5.15.0.70.75",
            "linux-lowlatency-hwe-20.04-edge": "5.15.0.70.75"
        }
    ]
}

Ubuntu:22.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1031.36

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gke": "5.15.0.1031.30",
            "linux-headers-gke": "5.15.0.1031.30",
            "linux-headers-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-tools-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-buildinfo-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-modules-iwlwifi-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-modules-extra-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-gke-5.15": "5.15.0.1031.30",
            "linux-gke": "5.15.0.1031.30",
            "linux-modules-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-image-gke-5.15": "5.15.0.1031.30",
            "linux-image-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-headers-gke-5.15": "5.15.0.1031.30",
            "linux-tools-gke-5.15": "5.15.0.1031.30",
            "linux-image-unsigned-5.15.0-1031-gke": "5.15.0-1031.36",
            "linux-gke-headers-5.15.0-1031": "5.15.0-1031.36",
            "linux-gke-tools-5.15.0-1031": "5.15.0-1031.36",
            "linux-tools-gke": "5.15.0.1031.30"
        }
    ]
}

Ubuntu:22.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1032.40

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.15.0.1032.27",
            "linux-image-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-modules-iwlwifi-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-modules-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-gcp-headers-5.15.0-1032": "5.15.0-1032.40",
            "linux-gcp": "5.15.0.1032.27",
            "linux-modules-extra-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-headers-gcp": "5.15.0.1032.27",
            "linux-image-gcp": "5.15.0.1032.27",
            "linux-modules-extra-gcp": "5.15.0.1032.27",
            "linux-gcp-tools-5.15.0-1032": "5.15.0-1032.40",
            "linux-buildinfo-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-tools-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-image-unsigned-5.15.0-1032-gcp": "5.15.0-1032.40",
            "linux-headers-5.15.0-1032-gcp": "5.15.0-1032.40"
        }
    ]
}

Ubuntu:22.04:LTS / linux-ibm

Package

Name
linux-ibm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1028.31

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-ibm-tools-5.15.0-1028": "5.15.0-1028.31",
            "linux-image-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-modules-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-headers-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-image-unsigned-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-buildinfo-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-tools-ibm": "5.15.0.1028.24",
            "linux-ibm-tools-common": "5.15.0-1028.31",
            "linux-modules-extra-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-headers-ibm": "5.15.0.1028.24",
            "linux-ibm": "5.15.0.1028.24",
            "linux-ibm-source-5.15.0": "5.15.0-1028.31",
            "linux-ibm-headers-5.15.0-1028": "5.15.0-1028.31",
            "linux-tools-5.15.0-1028-ibm": "5.15.0-1028.31",
            "linux-image-ibm": "5.15.0.1028.24",
            "linux-ibm-cloud-tools-common": "5.15.0-1028.31"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws-5.15

Package

Name
linux-aws-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1034.38~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-modules-extra-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-image-aws-edge": "5.15.0.1034.38~20.04.23",
            "linux-cloud-tools-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-headers-aws": "5.15.0.1034.38~20.04.23",
            "linux-modules-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-headers-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-image-aws": "5.15.0.1034.38~20.04.23",
            "linux-aws-5.15-tools-5.15.0-1034": "5.15.0-1034.38~20.04.1",
            "linux-image-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-aws": "5.15.0.1034.38~20.04.23",
            "linux-headers-aws-edge": "5.15.0.1034.38~20.04.23",
            "linux-tools-aws-edge": "5.15.0.1034.38~20.04.23",
            "linux-modules-extra-aws-edge": "5.15.0.1034.38~20.04.23",
            "linux-modules-extra-aws": "5.15.0.1034.38~20.04.23",
            "linux-aws-5.15-headers-5.15.0-1034": "5.15.0-1034.38~20.04.1",
            "linux-buildinfo-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-aws-5.15-cloud-tools-5.15.0-1034": "5.15.0-1034.38~20.04.1",
            "linux-aws-edge": "5.15.0.1034.38~20.04.23",
            "linux-tools-5.15.0-1034-aws": "5.15.0-1034.38~20.04.1",
            "linux-tools-aws": "5.15.0.1034.38~20.04.23"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle-5.15

Package

Name
linux-oracle-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1033.39~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-modules-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-headers-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-oracle-5.15-headers-5.15.0-1033": "5.15.0-1033.39~20.04.1",
            "linux-image-unsigned-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-tools-oracle-edge": "5.15.0.1033.39~20.04.1",
            "linux-oracle": "5.15.0.1033.39~20.04.1",
            "linux-oracle-5.15-tools-5.15.0-1033": "5.15.0-1033.39~20.04.1",
            "linux-modules-extra-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-headers-oracle": "5.15.0.1033.39~20.04.1",
            "linux-oracle-edge": "5.15.0.1033.39~20.04.1",
            "linux-image-oracle-edge": "5.15.0.1033.39~20.04.1",
            "linux-headers-oracle-edge": "5.15.0.1033.39~20.04.1",
            "linux-buildinfo-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1",
            "linux-tools-oracle": "5.15.0.1033.39~20.04.1",
            "linux-image-oracle": "5.15.0.1033.39~20.04.1",
            "linux-tools-5.15.0-1033-oracle": "5.15.0-1033.39~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure-5.15

Package

Name
linux-azure-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1036.43~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-tools-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-modules-extra-azure": "5.15.0.1036.43~20.04.26",
            "linux-azure-5.15-tools-5.15.0-1036": "5.15.0-1036.43~20.04.1",
            "linux-tools-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-headers-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-azure-5.15-headers-5.15.0-1036": "5.15.0-1036.43~20.04.1",
            "linux-headers-azure-edge": "5.15.0.1036.43~20.04.26",
            "linux-headers-azure": "5.15.0.1036.43~20.04.26",
            "linux-azure-5.15-cloud-tools-5.15.0-1036": "5.15.0-1036.43~20.04.1",
            "linux-headers-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-modules-extra-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-azure": "5.15.0.1036.43~20.04.26",
            "linux-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-modules-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-image-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-cloud-tools-azure-cvm": "5.15.0.1036.43~20.04.26",
            "linux-azure-edge": "5.15.0.1036.43~20.04.26",
            "linux-buildinfo-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-tools-azure-edge": "5.15.0.1036.43~20.04.26",
            "linux-cloud-tools-azure": "5.15.0.1036.43~20.04.26",
            "linux-cloud-tools-azure-edge": "5.15.0.1036.43~20.04.26",
            "linux-tools-azure": "5.15.0.1036.43~20.04.26",
            "linux-modules-extra-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-image-azure": "5.15.0.1036.43~20.04.26",
            "linux-cloud-tools-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-image-azure-edge": "5.15.0.1036.43~20.04.26",
            "linux-image-5.15.0-1036-azure": "5.15.0-1036.43~20.04.1",
            "linux-modules-extra-azure-edge": "5.15.0.1036.43~20.04.26"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp-5.15

Package

Name
linux-gcp-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1032.40~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.15.0.1032.40~20.04.1",
            "linux-image-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-modules-iwlwifi-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-headers-gcp-edge": "5.15.0.1032.40~20.04.1",
            "linux-modules-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-gcp": "5.15.0.1032.40~20.04.1",
            "linux-tools-gcp-edge": "5.15.0.1032.40~20.04.1",
            "linux-image-gcp-edge": "5.15.0.1032.40~20.04.1",
            "linux-modules-extra-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-image-gcp": "5.15.0.1032.40~20.04.1",
            "linux-headers-gcp": "5.15.0.1032.40~20.04.1",
            "linux-modules-extra-gcp": "5.15.0.1032.40~20.04.1",
            "linux-gcp-edge": "5.15.0.1032.40~20.04.1",
            "linux-buildinfo-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-gcp-5.15-headers-5.15.0-1032": "5.15.0-1032.40~20.04.1",
            "linux-modules-extra-gcp-edge": "5.15.0.1032.40~20.04.1",
            "linux-gcp-5.15-tools-5.15.0-1032": "5.15.0-1032.40~20.04.1",
            "linux-tools-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-image-unsigned-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1",
            "linux-headers-5.15.0-1032-gcp": "5.15.0-1032.40~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gke-5.15

Package

Name
linux-gke-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1031.36~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-gke-edge": "5.15.0.1031.36~20.04.1",
            "linux-gke-5.15-headers-5.15.0-1031": "5.15.0-1031.36~20.04.1",
            "linux-headers-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-tools-gke-edge": "5.15.0.1031.36~20.04.1",
            "linux-buildinfo-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-modules-iwlwifi-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-modules-extra-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-gke-5.15": "5.15.0.1031.36~20.04.1",
            "linux-tools-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-modules-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-image-gke-5.15": "5.15.0.1031.36~20.04.1",
            "linux-image-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1",
            "linux-gke-edge": "5.15.0.1031.36~20.04.1",
            "linux-gke-5.15-tools-5.15.0-1031": "5.15.0-1031.36~20.04.1",
            "linux-headers-gke-5.15": "5.15.0.1031.36~20.04.1",
            "linux-image-gke-edge": "5.15.0.1031.36~20.04.1",
            "linux-tools-gke-5.15": "5.15.0.1031.36~20.04.1",
            "linux-image-unsigned-5.15.0-1031-gke": "5.15.0-1031.36~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-lowlatency-hwe-5.15

Package

Name
linux-lowlatency-hwe-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-70.77~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-headers-lowlatency-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-tools-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-tools-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-headers-lowlatency-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-cloud-tools-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-image-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-image-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-buildinfo-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-64k-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-lowlatency-hwe-5.15-cloud-tools-common": "5.15.0-70.77~20.04.1",
            "linux-headers-lowlatency-64k-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-image-lowlatency-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-tools-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-64k-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-image-lowlatency-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-tools-lowlatency-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-headers-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-image-unsigned-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-buildinfo-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-hwe-5.15-tools-5.15.0-70": "5.15.0-70.77~20.04.1",
            "linux-image-unsigned-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-modules-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-headers-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-hwe-5.15-cloud-tools-5.15.0-70": "5.15.0-70.77~20.04.1",
            "linux-tools-lowlatency-64k-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-image-lowlatency-64k-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-tools-lowlatency-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-modules-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-modules-iwlwifi-5.15.0-70-lowlatency": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-hwe-5.15-tools-common": "5.15.0-70.77~20.04.1",
            "linux-image-5.15.0-70-lowlatency-64k": "5.15.0-70.77~20.04.1",
            "linux-lowlatency-hwe-5.15-tools-host": "5.15.0-70.77~20.04.1",
            "linux-cloud-tools-lowlatency-hwe-20.04": "5.15.0.70.77~20.04.28",
            "linux-lowlatency-hwe-5.15-headers-5.15.0-70": "5.15.0-70.77~20.04.1",
            "linux-cloud-tools-lowlatency-hwe-20.04-edge": "5.15.0.70.77~20.04.28",
            "linux-lowlatency-hwe-20.04-edge": "5.15.0.70.77~20.04.28"
        }
    ]
}