USN-6073-7

See a problem?
Source
https://ubuntu.com/security/notices/USN-6073-7
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6073-7.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6073-7
Published
2023-05-23T11:49:07.371907Z
Modified
2023-05-23T11:49:07.371907Z
Summary
python-glance-store regression
Details

USN-6073-2 fixed a vulnerability in Glance_store. Unfortunately the update introduced a regression with detaching volumes. The security fix has been removed pending further investigation.

We apologize for the inconvenience.

Original advisory details:

Jan Wasilewski and Gorka Eguileor discovered that Glance_store incorrectly handled deleted volume attachments. An authenticated user or attacker could possibly use this issue to gain access to sensitive information.

This update may require configuration changes to be completely effective, please see the upstream advisory for more information:

https://security.openstack.org/ossa/OSSA-2023-003.html

References

Affected packages

Ubuntu:22.04:LTS / python-glance-store

Package

Name
python-glance-store

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.0-0ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-glance-store": "3.0.0-0ubuntu1.2",
            "python-glance-store-doc": "3.0.0-0ubuntu1.2"
        }
    ]
}

Ubuntu:20.04:LTS / python-glance-store

Package

Name
python-glance-store

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.0-0ubuntu4.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-glance-store": "2.0.0-0ubuntu4.2",
            "python-glance-store-doc": "2.0.0-0ubuntu4.2"
        }
    ]
}