USN-6078-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6078-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6078-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6078-2
Related
Published
2023-07-18T11:26:04.504268Z
Modified
2023-07-18T11:26:04.504268Z
Summary
libwebp vulnerability
Details

USN-6078-1 fixed a vulnerability in libwebp. This update provides the corresponding update for Ubuntu 16.04 LTS.

Original advisory details:

Irvan Kurniawan discovered that libwebp incorrectly handled certain memory operations. If a user or automated system were tricked into opening a specially crafted image file, a remote attacker could use this issue to cause libwebp to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:16.04:LTS / libwebp

Package

Name
libwebp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.4-1ubuntu0.1~esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libwebpdemux1": "0.4.4-1ubuntu0.1~esm2",
            "webp": "0.4.4-1ubuntu0.1~esm2",
            "libwebpmux1": "0.4.4-1ubuntu0.1~esm2",
            "libwebp-dev": "0.4.4-1ubuntu0.1~esm2",
            "libwebp5": "0.4.4-1ubuntu0.1~esm2"
        }
    ]
}