USN-6102-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6102-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6102-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6102-1
Related
Published
2023-05-24T09:57:50.486376Z
Modified
2023-05-24T09:57:50.486376Z
Summary
node-xmldom vulnerabilities
Details

It was discovered that xmldom incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause unexpected syntactic changes during XML processing. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-21366)

It was discovered that xmldom incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service. (CVE-2022-37616, CVE-2022-39353)

References

Affected packages

Ubuntu:22.04:LTS / node-xmldom

Package

Name
node-xmldom

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.5-1ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "node-xmldom": "0.7.5-1ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / node-xmldom

Package

Name
node-xmldom

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.1.27+ds-1+deb10u2build0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "node-xmldom": "0.1.27+ds-1+deb10u2build0.20.04.1"
        }
    ]
}