USN-6104-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6104-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6104-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6104-1
Related
Published
2023-05-24T14:16:06.626936Z
Modified
2023-05-24T14:16:06.626936Z
Summary
postgresql-10, postgresql-12, postgresql-14, postgresql-15 vulnerabilities
Details

Alexander Lakhin discovered that PostgreSQL incorrectly handled certain CREATE privileges. An authenticated user could possibly use this issue to execute arbitrary code as the bootstrap supervisor. (CVE-2023-2454)

Wolfgang Walther discovered that PostgreSQL incorrectly handled certain row security policies. An authenticated user could possibly use this issue to complete otherwise forbidden reads and modifications. (CVE-2023-2455)

References

Affected packages

Ubuntu:22.04:LTS / postgresql-14

Package

Name
postgresql-14

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
14.8-0ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "postgresql-client-14": "14.8-0ubuntu0.22.04.1",
            "libpq-dev": "14.8-0ubuntu0.22.04.1",
            "libecpg6": "14.8-0ubuntu0.22.04.1",
            "libpgtypes3": "14.8-0ubuntu0.22.04.1",
            "postgresql-doc-14": "14.8-0ubuntu0.22.04.1",
            "postgresql-server-dev-14": "14.8-0ubuntu0.22.04.1",
            "libecpg-dev": "14.8-0ubuntu0.22.04.1",
            "postgresql-pltcl-14": "14.8-0ubuntu0.22.04.1",
            "postgresql-plperl-14": "14.8-0ubuntu0.22.04.1",
            "libpq5": "14.8-0ubuntu0.22.04.1",
            "postgresql-14": "14.8-0ubuntu0.22.04.1",
            "libecpg-compat3": "14.8-0ubuntu0.22.04.1",
            "postgresql-plpython3-14": "14.8-0ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / postgresql-12

Package

Name
postgresql-12

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.15-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpq-dev": "12.15-0ubuntu0.20.04.1",
            "libecpg6": "12.15-0ubuntu0.20.04.1",
            "postgresql-plpython3-12": "12.15-0ubuntu0.20.04.1",
            "postgresql-doc-12": "12.15-0ubuntu0.20.04.1",
            "libpgtypes3": "12.15-0ubuntu0.20.04.1",
            "postgresql-pltcl-12": "12.15-0ubuntu0.20.04.1",
            "libecpg-dev": "12.15-0ubuntu0.20.04.1",
            "postgresql-plperl-12": "12.15-0ubuntu0.20.04.1",
            "postgresql-server-dev-12": "12.15-0ubuntu0.20.04.1",
            "postgresql-12": "12.15-0ubuntu0.20.04.1",
            "postgresql-client-12": "12.15-0ubuntu0.20.04.1",
            "libpq5": "12.15-0ubuntu0.20.04.1",
            "libecpg-compat3": "12.15-0ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / postgresql-10

Package

Name
postgresql-10

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.23-0ubuntu0.18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "10.23-0ubuntu0.18.04.2",
            "libecpg-dev": "10.23-0ubuntu0.18.04.2",
            "postgresql-plperl-10": "10.23-0ubuntu0.18.04.2",
            "libpq5": "10.23-0ubuntu0.18.04.2",
            "postgresql-client-10": "10.23-0ubuntu0.18.04.2",
            "libpq-dev": "10.23-0ubuntu0.18.04.2",
            "libpgtypes3": "10.23-0ubuntu0.18.04.2",
            "postgresql-10": "10.23-0ubuntu0.18.04.2",
            "postgresql-doc-10": "10.23-0ubuntu0.18.04.2",
            "postgresql-plpython-10": "10.23-0ubuntu0.18.04.2",
            "libecpg-compat3": "10.23-0ubuntu0.18.04.2",
            "postgresql-server-dev-10": "10.23-0ubuntu0.18.04.2",
            "postgresql-pltcl-10": "10.23-0ubuntu0.18.04.2",
            "postgresql-plpython3-10": "10.23-0ubuntu0.18.04.2"
        }
    ]
}