USN-6112-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6112-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6112-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6112-1
Related
Published
2023-05-29T18:16:29.472803Z
Modified
2023-05-29T18:16:29.472803Z
Summary
perl vulnerability
Details

It was discovered that Perl was not properly verifying TLS certificates when using CPAN together with HTTP::Tiny to download modules over HTTPS. If a remote attacker were able to intercept communications, this flaw could potentially be used to install altered modules.

References

Affected packages

Ubuntu:Pro:14.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.18.2-2ubuntu1.7+esm5

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "perl-debug": "5.18.2-2ubuntu1.7+esm5",
            "perl": "5.18.2-2ubuntu1.7+esm5",
            "perl-modules": "5.18.2-2ubuntu1.7+esm5",
            "libperl5.18": "5.18.2-2ubuntu1.7+esm5",
            "libperl-dev": "5.18.2-2ubuntu1.7+esm5",
            "libcgi-fast-perl": "5.18.2-2ubuntu1.7+esm5",
            "perl-doc": "5.18.2-2ubuntu1.7+esm5",
            "perl-base": "5.18.2-2ubuntu1.7+esm5"
        }
    ]
}

Ubuntu:18.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.26.1-6ubuntu0.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-debug": "5.26.1-6ubuntu0.7",
            "perl": "5.26.1-6ubuntu0.7",
            "libperl-dev": "5.26.1-6ubuntu0.7",
            "libperl5.26": "5.26.1-6ubuntu0.7",
            "perl-doc": "5.26.1-6ubuntu0.7",
            "perl-modules-5.26": "5.26.1-6ubuntu0.7",
            "perl-base": "5.26.1-6ubuntu0.7"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.22.1-9ubuntu0.9+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "perl-debug": "5.22.1-9ubuntu0.9+esm2",
            "perl-modules-5.22": "5.22.1-9ubuntu0.9+esm2",
            "perl": "5.22.1-9ubuntu0.9+esm2",
            "libperl-dev": "5.22.1-9ubuntu0.9+esm2",
            "libperl5.22": "5.22.1-9ubuntu0.9+esm2",
            "perl-doc": "5.22.1-9ubuntu0.9+esm2",
            "perl-base": "5.22.1-9ubuntu0.9+esm2"
        }
    ]
}