USN-6112-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6112-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6112-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6112-2
Related
Published
2023-06-05T10:31:20.528349Z
Modified
2023-06-05T10:31:20.528349Z
Summary
perl vulnerability
Details

USN-6112-1 fixed vulnerabilities in Perl. This update provides the corresponding updates for Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 22.10, and Ubuntu 23.04.

Original advisory details:

It was discovered that Perl was not properly verifying TLS certificates when using CPAN together with HTTP::Tiny to download modules over HTTPS. If a remote attacker were able to intercept communications, this flaw could potentially be used to install altered modules.

References

Affected packages

Ubuntu:22.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.34.0-3ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-debug": "5.34.0-3ubuntu1.2",
            "perl": "5.34.0-3ubuntu1.2",
            "libperl5.34": "5.34.0-3ubuntu1.2",
            "libperl-dev": "5.34.0-3ubuntu1.2",
            "perl-modules-5.34": "5.34.0-3ubuntu1.2",
            "perl-doc": "5.34.0-3ubuntu1.2",
            "perl-base": "5.34.0-3ubuntu1.2"
        }
    ]
}

Ubuntu:20.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.30.0-9ubuntu0.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-modules-5.30": "5.30.0-9ubuntu0.4",
            "perl": "5.30.0-9ubuntu0.4",
            "perl-debug": "5.30.0-9ubuntu0.4",
            "libperl-dev": "5.30.0-9ubuntu0.4",
            "libperl5.30": "5.30.0-9ubuntu0.4",
            "perl-doc": "5.30.0-9ubuntu0.4",
            "perl-base": "5.30.0-9ubuntu0.4"
        }
    ]
}