USN-6128-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6128-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6128-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6128-1
Related
Published
2023-06-01T12:56:34.753039Z
Modified
2023-06-01T12:56:34.753039Z
Summary
cups vulnerability
Details

It was discovered that CUPS incorrectly handled logging. A remote attacker could use this issue to cause CUPS to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:22.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.1op1-1ubuntu4.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "2.4.1op1-1ubuntu4.2",
            "cups-bsd": "2.4.1op1-1ubuntu4.2",
            "cups-core-drivers": "2.4.1op1-1ubuntu4.2",
            "cups-ipp-utils": "2.4.1op1-1ubuntu4.2",
            "cups": "2.4.1op1-1ubuntu4.2",
            "cups-ppdc": "2.4.1op1-1ubuntu4.2",
            "cups-client": "2.4.1op1-1ubuntu4.2",
            "libcupsimage2-dev": "2.4.1op1-1ubuntu4.2",
            "cups-daemon": "2.4.1op1-1ubuntu4.2",
            "cups-common": "2.4.1op1-1ubuntu4.2",
            "libcupsimage2": "2.4.1op1-1ubuntu4.2",
            "cups-server-common": "2.4.1op1-1ubuntu4.2",
            "libcups2-dev": "2.4.1op1-1ubuntu4.2"
        }
    ]
}

Ubuntu:20.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-9ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "2.3.1-9ubuntu1.3",
            "cups-bsd": "2.3.1-9ubuntu1.3",
            "cups-core-drivers": "2.3.1-9ubuntu1.3",
            "cups-ipp-utils": "2.3.1-9ubuntu1.3",
            "cups": "2.3.1-9ubuntu1.3",
            "cups-ppdc": "2.3.1-9ubuntu1.3",
            "cups-client": "2.3.1-9ubuntu1.3",
            "libcupsimage2-dev": "2.3.1-9ubuntu1.3",
            "cups-daemon": "2.3.1-9ubuntu1.3",
            "cups-common": "2.3.1-9ubuntu1.3",
            "libcupsimage2": "2.3.1-9ubuntu1.3",
            "cups-server-common": "2.3.1-9ubuntu1.3",
            "libcups2-dev": "2.3.1-9ubuntu1.3"
        }
    ]
}

Ubuntu:18.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.7-1ubuntu2.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "2.2.7-1ubuntu2.10",
            "libcupsppdc1": "2.2.7-1ubuntu2.10",
            "cups-ipp-utils": "2.2.7-1ubuntu2.10",
            "cups": "2.2.7-1ubuntu2.10",
            "cups-client": "2.2.7-1ubuntu2.10",
            "libcupsimage2-dev": "2.2.7-1ubuntu2.10",
            "libcupsmime1": "2.2.7-1ubuntu2.10",
            "cups-common": "2.2.7-1ubuntu2.10",
            "libcupsimage2": "2.2.7-1ubuntu2.10",
            "cups-server-common": "2.2.7-1ubuntu2.10",
            "libcupscgi1": "2.2.7-1ubuntu2.10",
            "cups-core-drivers": "2.2.7-1ubuntu2.10",
            "cups-ppdc": "2.2.7-1ubuntu2.10",
            "cups-bsd": "2.2.7-1ubuntu2.10",
            "cups-daemon": "2.2.7-1ubuntu2.10",
            "libcups2-dev": "2.2.7-1ubuntu2.10"
        }
    ]
}