USN-6148-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6148-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6148-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6148-1
Related
Published
2023-06-12T13:20:44.091188Z
Modified
2023-06-12T13:20:44.091188Z
Summary
sniproxy vulnerability
Details

It was discovered that SNI Proxy did not properly handle wildcard backend hosts. An attacker could possibly use this issue to cause a buffer overflow, resulting in a denial of service, or arbitrary code execution.

References

Affected packages

Ubuntu:22.04:LTS / sniproxy

Package

Name
sniproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.0-2ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "sniproxy": "0.6.0-2ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / sniproxy

Package

Name
sniproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.0-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "sniproxy": "0.6.0-1ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / sniproxy

Package

Name
sniproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.5.0-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "sniproxy": "0.5.0-2ubuntu0.1~esm1"
        }
    ]
}