USN-6156-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6156-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6156-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6156-1
Related
Published
2023-06-12T12:00:14.158113Z
Modified
2023-06-12T12:00:14.158113Z
Summary
sssd vulnerability
Details

It was discovered that SSSD incorrrectly sanitized certificate data used in LDAP filters. When using this issue in combination with FreeIPA, a remote attacker could possibly use this issue to escalate privileges.

References

Affected packages

Ubuntu:20.04:LTS / sssd

Package

Name
sssd

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.3-3ubuntu0.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "sssd-ldap": "2.2.3-3ubuntu0.11",
            "libsss-idmap-dev": "2.2.3-3ubuntu0.11",
            "python3-sss": "2.2.3-3ubuntu0.11",
            "sssd-ipa": "2.2.3-3ubuntu0.11",
            "libpam-sss": "2.2.3-3ubuntu0.11",
            "libipa-hbac-dev": "2.2.3-3ubuntu0.11",
            "libsss-idmap0": "2.2.3-3ubuntu0.11",
            "sssd-ad": "2.2.3-3ubuntu0.11",
            "libwbclient-sssd": "2.2.3-3ubuntu0.11",
            "sssd": "2.2.3-3ubuntu0.11",
            "sssd-krb5-common": "2.2.3-3ubuntu0.11",
            "libnss-sss": "2.2.3-3ubuntu0.11",
            "libsss-nss-idmap-dev": "2.2.3-3ubuntu0.11",
            "sssd-proxy": "2.2.3-3ubuntu0.11",
            "python3-libsss-nss-idmap": "2.2.3-3ubuntu0.11",
            "sssd-krb5": "2.2.3-3ubuntu0.11",
            "libsss-certmap0": "2.2.3-3ubuntu0.11",
            "libwbclient-sssd-dev": "2.2.3-3ubuntu0.11",
            "libsss-nss-idmap0": "2.2.3-3ubuntu0.11",
            "libsss-simpleifp-dev": "2.2.3-3ubuntu0.11",
            "libsss-certmap-dev": "2.2.3-3ubuntu0.11",
            "sssd-dbus": "2.2.3-3ubuntu0.11",
            "python3-libipa-hbac": "2.2.3-3ubuntu0.11",
            "sssd-ad-common": "2.2.3-3ubuntu0.11",
            "libsss-sudo": "2.2.3-3ubuntu0.11",
            "libsss-simpleifp0": "2.2.3-3ubuntu0.11",
            "sssd-common": "2.2.3-3ubuntu0.11",
            "libipa-hbac0": "2.2.3-3ubuntu0.11",
            "sssd-tools": "2.2.3-3ubuntu0.11",
            "sssd-kcm": "2.2.3-3ubuntu0.11"
        }
    ]
}