USN-6158-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6158-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6158-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6158-1
Related
Published
2023-06-13T14:07:10.238681Z
Modified
2023-06-13T14:07:10.238681Z
Summary
node-fetch vulnerability
Details

It was discovered that Node Fetch incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / node-fetch

Package

Name
node-fetch

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.3-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "node-fetch": "1.7.3-2ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / node-fetch

Package

Name
node-fetch

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.3-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "node-fetch": "1.7.3-1ubuntu0.1~esm1"
        }
    ]
}