USN-6168-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6168-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6168-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6168-2
Related
Published
2023-06-20T10:12:13.350985Z
Modified
2023-06-20T10:12:13.350985Z
Summary
libx11 vulnerability
Details

USN-6168-1 fixed a vulnerability in libx11. This update provides the corresponding update for Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, and Ubuntu 18.04 ESM.

Original advisory details:

Gregory James Duck discovered that libx11 incorrectly handled certain Request, Event, or Error IDs. If a user were tricked into connecting to a malicious X Server, a remote attacker could possibly use this issue to cause libx11 to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:Pro:18.04:LTS / libx11

Package

Name
libx11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.6.4-3ubuntu0.4+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libx11-data": "2:1.6.4-3ubuntu0.4+esm1",
            "libx11-6": "2:1.6.4-3ubuntu0.4+esm1",
            "libx11-xcb-dev": "2:1.6.4-3ubuntu0.4+esm1",
            "libx11-xcb1": "2:1.6.4-3ubuntu0.4+esm1",
            "libx11-doc": "2:1.6.4-3ubuntu0.4+esm1",
            "libx11-dev": "2:1.6.4-3ubuntu0.4+esm1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / libx11

Package

Name
libx11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.6.2-1ubuntu2.1+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libx11-data": "2:1.6.2-1ubuntu2.1+esm3",
            "libx11-6": "2:1.6.2-1ubuntu2.1+esm3",
            "libx11-xcb-dev": "2:1.6.2-1ubuntu2.1+esm3",
            "libx11-xcb1": "2:1.6.2-1ubuntu2.1+esm3",
            "libx11-doc": "2:1.6.2-1ubuntu2.1+esm3",
            "libx11-dev": "2:1.6.2-1ubuntu2.1+esm3"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libx11

Package

Name
libx11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.6.3-1ubuntu2.2+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libx11-data": "2:1.6.3-1ubuntu2.2+esm2",
            "libx11-6": "2:1.6.3-1ubuntu2.2+esm2",
            "libx11-xcb-dev": "2:1.6.3-1ubuntu2.2+esm2",
            "libx11-xcb1": "2:1.6.3-1ubuntu2.2+esm2",
            "libx11-doc": "2:1.6.3-1ubuntu2.2+esm2",
            "libx11-dev": "2:1.6.3-1ubuntu2.2+esm2"
        }
    ]
}