USN-6176-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6176-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6176-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6176-1
Related
Published
2023-06-19T05:54:25.458584Z
Modified
2023-06-19T05:54:25.458584Z
Summary
pypdf2 vulnerability
Details

It was discovered that PyPDF2 incorrectly handled certain PDF files. If a user or automated system were tricked into processing a specially crafted file, an attacker could possibly use this issue to consume system resources, resulting in a denial of service.

References

Affected packages

Ubuntu:22.04:LTS / pypdf2

Package

Name
pypdf2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.26.0-4ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-pypdf2": "1.26.0-4ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / pypdf2

Package

Name
pypdf2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.26.0-3ubuntu1.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-pypdf2": "1.26.0-3ubuntu1.20.04.1",
            "python3-pypdf2": "1.26.0-3ubuntu1.20.04.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / pypdf2

Package

Name
pypdf2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.26.0-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-pypdf2": "1.26.0-2ubuntu0.1~esm1",
            "python3-pypdf2": "1.26.0-2ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / pypdf2

Package

Name
pypdf2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.25.1-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-pypdf2": "1.25.1-1ubuntu0.1~esm1",
            "python3-pypdf2": "1.25.1-1ubuntu0.1~esm1"
        }
    ]
}