USN-6192-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6192-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6192-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6192-1
Related
  • CVE-2023-2430
  • CVE-2023-35788
Published
2023-06-29T12:38:56.405968Z
Modified
2023-06-29T12:38:56.405968Z
Summary
linux, linux-allwinner, linux-allwinner-5.19, linux-aws, linux-aws-5.19, linux-azure, linux-gcp, linux-gcp-5.19, linux-hwe-5.19, linux-ibm, linux-kvm, linux-lowlatency, linux-oracle, linux-raspi, linux-starfive, linux-starfive-5.19 vulnerabilities
Details

Hangyu Hua discovered that the Flower classifier implementation in the Linux kernel contained an out-of-bounds write vulnerability. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-35788, LP: #2023577)

Xingyuan Mo and Gengjia Chen discovered that the io_uring subsystem in the Linux kernel did not properly handle locking when IOPOLL mode is being used. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-2430)

It was discovered that for some Intel processors the INVLPG instruction implementation did not properly flush global TLB entries when PCIDs are enabled. An attacker could use this to expose sensitive information (kernel memory) or possibly cause undesired behaviors. (LP: #2023220)

References

Affected packages

Ubuntu:22.04:LTS / linux-allwinner-5.19

Package

Name
linux-allwinner-5.19

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.19.0-1015.15~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-allwinner-5.19-headers-5.19.0-1015": "5.19.0-1015.15~22.04.1",
            "linux-headers-allwinner": "5.19.0.1015.15~22.04.8",
            "linux-modules-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1",
            "linux-tools-allwinner": "5.19.0.1015.15~22.04.8",
            "linux-modules-extra-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1",
            "linux-allwinner": "5.19.0.1015.15~22.04.8",
            "linux-buildinfo-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1",
            "linux-allwinner-5.19-tools-5.19.0-1015": "5.19.0-1015.15~22.04.1",
            "linux-image-allwinner": "5.19.0.1015.15~22.04.8",
            "linux-image-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1",
            "linux-tools-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1",
            "linux-headers-5.19.0-1015-allwinner": "5.19.0-1015.15~22.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / linux-aws-5.19

Package

Name
linux-aws-5.19

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.19.0-1028.29~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-modules-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-tools-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-modules-extra-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-headers-aws": "5.19.0.1028.29~22.04.12",
            "linux-aws-5.19-tools-5.19.0-1028": "5.19.0-1028.29~22.04.1",
            "linux-aws-5.19-headers-5.19.0-1028": "5.19.0-1028.29~22.04.1",
            "linux-aws": "5.19.0.1028.29~22.04.12",
            "linux-image-aws": "5.19.0.1028.29~22.04.12",
            "linux-buildinfo-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-cloud-tools-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-modules-extra-aws": "5.19.0.1028.29~22.04.12",
            "linux-image-unsigned-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-image-5.19.0-1028-aws": "5.19.0-1028.29~22.04.1",
            "linux-aws-5.19-cloud-tools-5.19.0-1028": "5.19.0-1028.29~22.04.1",
            "linux-tools-aws": "5.19.0.1028.29~22.04.12"
        }
    ]
}

Ubuntu:22.04:LTS / linux-gcp-5.19

Package

Name
linux-gcp-5.19

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.19.0-1027.29~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.19.0.1027.29~22.04.1",
            "linux-gcp-5.19-tools-5.19.0-1027": "5.19.0-1027.29~22.04.1",
            "linux-image-unsigned-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-modules-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-headers-gcp-edge": "5.19.0.1027.29~22.04.1",
            "linux-gcp": "5.19.0.1027.29~22.04.1",
            "linux-tools-gcp-edge": "5.19.0.1027.29~22.04.1",
            "linux-tools-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-image-gcp-edge": "5.19.0.1027.29~22.04.1",
            "linux-headers-gcp": "5.19.0.1027.29~22.04.1",
            "linux-image-gcp": "5.19.0.1027.29~22.04.1",
            "linux-modules-extra-gcp": "5.19.0.1027.29~22.04.1",
            "linux-gcp-edge": "5.19.0.1027.29~22.04.1",
            "linux-headers-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-modules-extra-gcp-edge": "5.19.0.1027.29~22.04.1",
            "linux-buildinfo-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-gcp-5.19-headers-5.19.0-1027": "5.19.0-1027.29~22.04.1",
            "linux-image-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1",
            "linux-modules-extra-5.19.0-1027-gcp": "5.19.0-1027.29~22.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / linux-hwe-5.19

Package

Name
linux-hwe-5.19

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.19.0-46.47~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.19.0-46-generic-lpae": "5.19.0-46.47~22.04.1",
            "linux-cloud-tools-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-image-extra-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-headers-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-hwe-5.19-tools-5.19.0-46": "5.19.0-46.47~22.04.1",
            "linux-tools-generic-64k-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-cloud-tools-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-image-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-image-unsigned-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-modules-ivsc-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-headers-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-modules-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-tools-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-image-generic-64k-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-modules-extra-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-tools-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-tools-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-buildinfo-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-headers-5.19.0-46-generic-lpae": "5.19.0-46.47~22.04.1",
            "linux-modules-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-modules-5.19.0-46-generic-lpae": "5.19.0-46.47~22.04.1",
            "linux-source-5.19.0": "5.19.0-46.47~22.04.1",
            "linux-cloud-tools-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-hwe-5.19-cloud-tools-common": "5.19.0-46.47~22.04.1",
            "linux-image-unsigned-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-generic-lpae-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-headers-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-image-5.19.0-46-generic-lpae": "5.19.0-46.47~22.04.1",
            "linux-generic-64k-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-modules-iwlwifi-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-image-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-modules-ipu6-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-image-virtual-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-tools-generic-lpae-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-hwe-5.19-headers-5.19.0-46": "5.19.0-46.47~22.04.1",
            "linux-image-generic-lpae-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-hwe-5.19-tools-common": "5.19.0-46.47~22.04.1",
            "linux-headers-generic-64k-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-headers-generic-lpae-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-modules-ivsc-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-tools-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-hwe-5.19-cloud-tools-5.19.0-46": "5.19.0-46.47~22.04.1",
            "linux-image-generic-hwe-22.04": "5.19.0.46.47~22.04.21",
            "linux-buildinfo-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-headers-5.19.0-46-generic-64k": "5.19.0-46.47~22.04.1",
            "linux-tools-5.19.0-46-generic-lpae": "5.19.0-46.47~22.04.1",
            "linux-modules-iwlwifi-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-modules-ipu6-5.19.0-46-generic": "5.19.0-46.47~22.04.1",
            "linux-hwe-5.19-tools-host": "5.19.0-46.47~22.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / linux-starfive-5.19

Package

Name
linux-starfive-5.19

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.19.0-1020.22~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-starfive-5.19-tools-5.19.0-1020": "5.19.0-1020.22~22.04.1",
            "linux-headers-starfive": "5.19.0.1020.22~22.04.7",
            "linux-tools-starfive": "5.19.0.1020.22~22.04.7",
            "linux-image-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-headers-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-starfive": "5.19.0.1020.22~22.04.7",
            "linux-starfive-5.19-headers-5.19.0-1020": "5.19.0-1020.22~22.04.1",
            "linux-buildinfo-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-tools-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-modules-extra-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-modules-5.19.0-1020-starfive": "5.19.0-1020.22~22.04.1",
            "linux-image-starfive": "5.19.0.1020.22~22.04.7"
        }
    ]
}