USN-6199-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6199-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6199-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6199-1
Related
Published
2023-07-03T14:38:17.535322Z
Modified
2023-07-03T14:38:17.535322Z
Summary
php7.4, php8.1 vulnerability
Details

It was discovered that PHP incorrectly handled certain Digest authentication for SOAP. An attacker could possibly use this issue to expose sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / php7.4

Package

Name
php7.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.4.3-4ubuntu2.19

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php7.4-cgi": "7.4.3-4ubuntu2.19",
            "php7.4-sqlite3": "7.4.3-4ubuntu2.19",
            "php7.4-interbase": "7.4.3-4ubuntu2.19",
            "php7.4-intl": "7.4.3-4ubuntu2.19",
            "php7.4-mysql": "7.4.3-4ubuntu2.19",
            "php7.4-gd": "7.4.3-4ubuntu2.19",
            "php7.4-xsl": "7.4.3-4ubuntu2.19",
            "php7.4-dba": "7.4.3-4ubuntu2.19",
            "php7.4-curl": "7.4.3-4ubuntu2.19",
            "php7.4-bz2": "7.4.3-4ubuntu2.19",
            "php7.4-gmp": "7.4.3-4ubuntu2.19",
            "libphp7.4-embed": "7.4.3-4ubuntu2.19",
            "php7.4-tidy": "7.4.3-4ubuntu2.19",
            "php7.4-dev": "7.4.3-4ubuntu2.19",
            "php7.4-snmp": "7.4.3-4ubuntu2.19",
            "php7.4-phpdbg": "7.4.3-4ubuntu2.19",
            "php7.4-imap": "7.4.3-4ubuntu2.19",
            "php7.4-mbstring": "7.4.3-4ubuntu2.19",
            "php7.4": "7.4.3-4ubuntu2.19",
            "php7.4-odbc": "7.4.3-4ubuntu2.19",
            "php7.4-bcmath": "7.4.3-4ubuntu2.19",
            "php7.4-pgsql": "7.4.3-4ubuntu2.19",
            "php7.4-pspell": "7.4.3-4ubuntu2.19",
            "php7.4-json": "7.4.3-4ubuntu2.19",
            "php7.4-xml": "7.4.3-4ubuntu2.19",
            "php7.4-enchant": "7.4.3-4ubuntu2.19",
            "php7.4-opcache": "7.4.3-4ubuntu2.19",
            "php7.4-sybase": "7.4.3-4ubuntu2.19",
            "php7.4-ldap": "7.4.3-4ubuntu2.19",
            "php7.4-zip": "7.4.3-4ubuntu2.19",
            "php7.4-fpm": "7.4.3-4ubuntu2.19",
            "libapache2-mod-php7.4": "7.4.3-4ubuntu2.19",
            "php7.4-common": "7.4.3-4ubuntu2.19",
            "php7.4-readline": "7.4.3-4ubuntu2.19",
            "php7.4-cli": "7.4.3-4ubuntu2.19",
            "php7.4-soap": "7.4.3-4ubuntu2.19",
            "php7.4-xmlrpc": "7.4.3-4ubuntu2.19"
        }
    ]
}

Ubuntu:22.04:LTS / php8.1

Package

Name
php8.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.1.2-1ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php8.1-pgsql": "8.1.2-1ubuntu2.13",
            "php8.1-bcmath": "8.1.2-1ubuntu2.13",
            "php8.1": "8.1.2-1ubuntu2.13",
            "libapache2-mod-php8.1": "8.1.2-1ubuntu2.13",
            "php8.1-xml": "8.1.2-1ubuntu2.13",
            "php8.1-cgi": "8.1.2-1ubuntu2.13",
            "php8.1-common": "8.1.2-1ubuntu2.13",
            "libphp8.1-embed": "8.1.2-1ubuntu2.13",
            "php8.1-tidy": "8.1.2-1ubuntu2.13",
            "php8.1-sybase": "8.1.2-1ubuntu2.13",
            "php8.1-dev": "8.1.2-1ubuntu2.13",
            "php8.1-ldap": "8.1.2-1ubuntu2.13",
            "php8.1-snmp": "8.1.2-1ubuntu2.13",
            "php8.1-gmp": "8.1.2-1ubuntu2.13",
            "php8.1-curl": "8.1.2-1ubuntu2.13",
            "php8.1-cli": "8.1.2-1ubuntu2.13",
            "php8.1-fpm": "8.1.2-1ubuntu2.13",
            "php8.1-mysql": "8.1.2-1ubuntu2.13",
            "php8.1-interbase": "8.1.2-1ubuntu2.13",
            "php8.1-gd": "8.1.2-1ubuntu2.13",
            "php8.1-enchant": "8.1.2-1ubuntu2.13",
            "php8.1-bz2": "8.1.2-1ubuntu2.13",
            "php8.1-dba": "8.1.2-1ubuntu2.13",
            "php8.1-readline": "8.1.2-1ubuntu2.13",
            "php8.1-xsl": "8.1.2-1ubuntu2.13",
            "php8.1-odbc": "8.1.2-1ubuntu2.13",
            "php8.1-zip": "8.1.2-1ubuntu2.13",
            "php8.1-imap": "8.1.2-1ubuntu2.13",
            "php8.1-phpdbg": "8.1.2-1ubuntu2.13",
            "libapache2-mod-php8.0": "8.1.2-1ubuntu2.13",
            "php8.1-opcache": "8.1.2-1ubuntu2.13",
            "php8.1-sqlite3": "8.1.2-1ubuntu2.13",
            "libapache2-mod-php7.4": "8.1.2-1ubuntu2.13",
            "php8.1-pspell": "8.1.2-1ubuntu2.13",
            "php8.1-intl": "8.1.2-1ubuntu2.13",
            "php8.1-mbstring": "8.1.2-1ubuntu2.13",
            "php8.1-soap": "8.1.2-1ubuntu2.13"
        }
    ]
}