USN-6249-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6249-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6249-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6249-1
Related
  • CVE-2023-3269
  • CVE-2023-3389
Published
2023-07-25T22:00:21.445367Z
Modified
2023-07-25T22:00:21.445367Z
Summary
linux-oem-6.1 vulnerabilities
Details

Ruihan Li discovered that the memory management subsystem in the Linux kernel contained a race condition when accessing VMAs in certain conditions, leading to a use-after-free vulnerability. A local attacker could possibly use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2023-3269)

Querijn Voet discovered that a race condition existed in the io_uring subsystem in the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-3389)

References

Affected packages

Ubuntu:22.04:LTS / linux-oem-6.1

Package

Name
linux-oem-6.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.1.0-1017.17

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-ivsc-oem-22.04c": "6.1.0.1017.17",
            "linux-modules-ipu6-oem-22.04c": "6.1.0.1017.17",
            "linux-modules-ivsc-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-oem-6.1-headers-6.1.0-1017": "6.1.0-1017.17",
            "linux-modules-iwlwifi-oem-22.04c": "6.1.0.1017.17",
            "linux-tools-oem-22.04c": "6.1.0.1017.17",
            "linux-image-oem-22.04c": "6.1.0.1017.17",
            "linux-modules-iwlwifi-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-headers-oem-22.04c": "6.1.0.1017.17",
            "linux-oem-22.04c": "6.1.0.1017.17",
            "linux-oem-6.1-tools-6.1.0-1017": "6.1.0-1017.17",
            "linux-tools-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-modules-ipu6-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-modules-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-image-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-headers-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-oem-6.1-tools-host": "6.1.0-1017.17",
            "linux-buildinfo-6.1.0-1017-oem": "6.1.0-1017.17",
            "linux-image-unsigned-6.1.0-1017-oem": "6.1.0-1017.17"
        }
    ]
}