USN-6267-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6267-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6267-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6267-1
Related
  • CVE-2023-4045
  • CVE-2023-4046
  • CVE-2023-4047
  • CVE-2023-4048
  • CVE-2023-4049
  • CVE-2023-4050
  • CVE-2023-4051
  • CVE-2023-4053
  • CVE-2023-4055
  • CVE-2023-4056
  • CVE-2023-4057
  • CVE-2023-4058
Published
2023-08-02T06:19:10.011580Z
Modified
2023-08-02T06:19:10.011580Z
Summary
firefox vulnerabilities
Details

Multiple security issues were discovered in Firefox. If a user were tricked into opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service, obtain sensitive information across domains, or execute arbitrary code. (CVE-2023-4047, CVE-2023-4048, CVE-2023-4049, CVE-2023-4051, CVE-2023-4053, CVE-2023-4055, CVE-2023-4056, CVE-2023-4057, CVE-2023-4058)

Max Vlasov discovered that Firefox Offscreen Canvas did not properly track cross-origin tainting. An attacker could potentially exploit this issue to access image data from another site in violation of same-origin policy. (CVE-2023-4045)

Alexander Guryanov discovered that Firefox did not properly update the value of a global variable in WASM JIT analysis in some circumstances. An attacker could potentially exploit this issue to cause a denial of service. (CVE-2023-4046)

Mark Brand discovered that Firefox did not properly validate the size of an untrusted input stream. An attacker could potentially exploit this issue to cause a denial of service. (CVE-2023-4050)

References

Affected packages

Ubuntu:20.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
116.0+build2-0ubuntu0.20.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-de": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-nl": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-kn": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-gl": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-fy": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-eo": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-km": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-or": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-az": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-lt": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-hy": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-kk": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sv": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-uk": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sr": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ca": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-is": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ne": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ga": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-it": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ja": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-lg": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ms": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-dev": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ia": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ko": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-hr": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-mai": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-nb": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-mozsymbols": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-vi": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-zh-hans": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-he": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sw": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-el": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-oc": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-xh": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-tg": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-nn": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-csb": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ar": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-cs": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-gn": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-hsb": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-zu": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-my": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ro": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-geckodriver": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-szl": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-af": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sk": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-nso": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-si": "116.0+build2-0ubuntu0.20.04.2",
            "firefox": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-cy": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-fa": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-cak": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sq": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-en": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-tr": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-br": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-et": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ast": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-th": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-da": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-fi": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ku": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-mn": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ru": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-mk": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-bg": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-hu": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-gu": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-bn": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-kab": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ml": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-an": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-be": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-eu": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-fr": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-pa": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-as": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-id": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-mr": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-bs": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-te": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-lv": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ka": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ta": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-gd": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-zh-hant": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-uz": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-hi": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-es": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-ur": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-pl": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-pt": "116.0+build2-0ubuntu0.20.04.2",
            "firefox-locale-sl": "116.0+build2-0ubuntu0.20.04.2"
        }
    ]
}