USN-6277-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6277-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6277-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6277-1
Related
  • CVE-2014-5011
  • CVE-2014-5012
  • CVE-2014-5013
  • CVE-2021-3838
  • CVE-2022-2400
Published
2023-08-08T14:10:26.486378Z
Modified
2023-08-08T14:10:26.486378Z
Summary
php-dompdf vulnerabilities
Details

It was discovered that Dompdf was not properly validating untrusted input when processing HTML content under certain circumstances. An attacker could possibly use this issue to expose sensitive information or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2014-5011, CVE-2014-5012, CVE-2014-5013)

It was discovered that Dompdf was not properly validating processed HTML content that referenced PHAR files, which could result in the deserialization of untrusted data. An attacker could possibly use this issue to execute arbitrary code. (CVE-2021-3838)

It was discovered that Dompdf was not properly validating processed HTML content that referenced both a remote base and a local file, which could result in the bypass of a chroot check. An attacker could possibly use this issue to expose sensitive information. (CVE-2022-2400)

References

Affected packages

Ubuntu:Pro:18.04:LTS / php-dompdf

Package

Name
php-dompdf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.2+dfsg-3ubuntu0.18.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "php-dompdf": "0.6.2+dfsg-3ubuntu0.18.04.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / php-dompdf

Package

Name
php-dompdf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.2+dfsg-3ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php-dompdf": "0.6.2+dfsg-3ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / php-dompdf

Package

Name
php-dompdf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1+dfsg-2ubuntu1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "php-dompdf": "0.6.1+dfsg-2ubuntu1+esm1"
        }
    ]
}