USN-6373-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6373-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6373-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6373-1
Related
  • CVE-2023-4156
Published
2023-09-14T18:55:29.273720Z
Modified
2023-09-14T18:55:29.273720Z
Summary
gawk vulnerability
Details

It was discovered that gawk could be made to read out of bounds when processing certain inputs. If a user or an automated system were tricked into opening a specially crafted input, an attacker could possibly use this issue to cause a denial of service.

References

Affected packages

Ubuntu:Pro:18.04:LTS / gawk

Package

Name
gawk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:4.1.4+dfsg-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "gawk": "1:4.1.4+dfsg-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / gawk

Package

Name
gawk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:5.0.1+dfsg-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gawk": "1:5.0.1+dfsg-1ubuntu0.1"
        }
    ]
}

Ubuntu:22.04:LTS / gawk

Package

Name
gawk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:5.1.0-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gawk": "1:5.1.0-1ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / gawk

Package

Name
gawk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:4.0.1+dfsg-2.1ubuntu2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "gawk": "1:4.0.1+dfsg-2.1ubuntu2+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / gawk

Package

Name
gawk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:4.1.3+dfsg-0.1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "gawk": "1:4.1.3+dfsg-0.1ubuntu0.1~esm1"
        }
    ]
}