USN-6386-3

See a problem?
Source
https://ubuntu.com/security/notices/USN-6386-3
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6386-3.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6386-3
Related
Published
2023-10-03T20:33:01.067307Z
Modified
2023-10-03T20:33:01.067307Z
Summary
linux-intel-iotg, linux-intel-iotg-5.15, linux-oracle, linux-oracle-5.15 vulnerabilities
Details

Jana Hofmann, Emanuele Vannacci, Cedric Fournet, Boris Kopf, and Oleksii Oleksenko discovered that some AMD processors could leak stale data from division operations in certain situations. A local attacker could possibly use this to expose sensitive information. (CVE-2023-20588)

It was discovered that the bluetooth subsystem in the Linux kernel did not properly handle L2CAP socket release, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-40283)

It was discovered that some network classifier implementations in the Linux kernel contained use-after-free vulnerabilities. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-4128)

Lonial Con discovered that the netfilter subsystem in the Linux kernel contained a memory leak when handling certain element flush operations. A local attacker could use this to expose sensitive information (kernel memory). (CVE-2023-4569)

References

Affected packages

Ubuntu:20.04:LTS / linux-intel-iotg-5.15

Package

Name
linux-intel-iotg-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1040.46~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-intel": "5.15.0.1040.46~20.04.31",
            "linux-tools-intel-iotg": "5.15.0.1040.46~20.04.31",
            "linux-intel-iotg": "5.15.0.1040.46~20.04.31",
            "linux-image-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-modules-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-image-unsigned-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-modules-iwlwifi-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-tools-intel": "5.15.0.1040.46~20.04.31",
            "linux-image-intel-iotg": "5.15.0.1040.46~20.04.31",
            "linux-intel-iotg-5.15-cloud-tools-common": "5.15.0-1040.46~20.04.1",
            "linux-tools-intel-iotg-edge": "5.15.0.1040.46~20.04.31",
            "linux-image-intel-iotg-edge": "5.15.0.1040.46~20.04.31",
            "linux-buildinfo-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-headers-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-intel-iotg-5.15-tools-common": "5.15.0-1040.46~20.04.1",
            "linux-headers-intel-iotg-edge": "5.15.0.1040.46~20.04.31",
            "linux-modules-extra-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-cloud-tools-intel": "5.15.0.1040.46~20.04.31",
            "linux-intel": "5.15.0.1040.46~20.04.31",
            "linux-cloud-tools-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-headers-intel-iotg": "5.15.0.1040.46~20.04.31",
            "linux-intel-iotg-5.15-tools-5.15.0-1040": "5.15.0-1040.46~20.04.1",
            "linux-intel-iotg-5.15-cloud-tools-5.15.0-1040": "5.15.0-1040.46~20.04.1",
            "linux-image-intel": "5.15.0.1040.46~20.04.31",
            "linux-intel-iotg-edge": "5.15.0.1040.46~20.04.31",
            "linux-intel-iotg-5.15-headers-5.15.0-1040": "5.15.0-1040.46~20.04.1",
            "linux-tools-5.15.0-1040-intel-iotg": "5.15.0-1040.46~20.04.1",
            "linux-intel-iotg-5.15-tools-host": "5.15.0-1040.46~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle-5.15

Package

Name
linux-oracle-5.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1044.50~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-modules-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-oracle-5.15-headers-5.15.0-1044": "5.15.0-1044.50~20.04.1",
            "linux-headers-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-tools-oracle-edge": "5.15.0.1044.50~20.04.1",
            "linux-oracle": "5.15.0.1044.50~20.04.1",
            "linux-oracle-5.15-tools-5.15.0-1044": "5.15.0-1044.50~20.04.1",
            "linux-image-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-buildinfo-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-modules-extra-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-headers-oracle": "5.15.0.1044.50~20.04.1",
            "linux-oracle-edge": "5.15.0.1044.50~20.04.1",
            "linux-headers-oracle-edge": "5.15.0.1044.50~20.04.1",
            "linux-image-oracle-edge": "5.15.0.1044.50~20.04.1",
            "linux-image-unsigned-5.15.0-1044-oracle": "5.15.0-1044.50~20.04.1",
            "linux-image-oracle": "5.15.0.1044.50~20.04.1",
            "linux-tools-oracle": "5.15.0.1044.50~20.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / linux-intel-iotg

Package

Name
linux-intel-iotg

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1040.46

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-intel-iotg-cloud-tools-5.15.0-1040": "5.15.0-1040.46",
            "linux-intel-iotg": "5.15.0.1040.40",
            "linux-modules-extra-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-image-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-cloud-tools-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-intel-iotg-headers-5.15.0-1040": "5.15.0-1040.46",
            "linux-headers-intel-iotg": "5.15.0.1040.40",
            "linux-intel-iotg-tools-host": "5.15.0-1040.46",
            "linux-modules-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-tools-intel-iotg": "5.15.0.1040.40",
            "linux-intel-iotg-cloud-tools-common": "5.15.0-1040.46",
            "linux-image-unsigned-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-intel-iotg-tools-5.15.0-1040": "5.15.0-1040.46",
            "linux-image-intel-iotg": "5.15.0.1040.40",
            "linux-intel-iotg-tools-common": "5.15.0-1040.46",
            "linux-modules-iwlwifi-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-buildinfo-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-headers-5.15.0-1040-intel-iotg": "5.15.0-1040.46",
            "linux-tools-5.15.0-1040-intel-iotg": "5.15.0-1040.46"
        }
    ]
}

Ubuntu:22.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.15.0-1044.50

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-oracle-lts-22.04": "5.15.0.1044.39",
            "linux-tools-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-modules-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-tools-oracle-lts-22.04": "5.15.0.1044.39",
            "linux-image-oracle-lts-22.04": "5.15.0.1044.39",
            "linux-headers-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-oracle-headers-5.15.0-1044": "5.15.0-1044.50",
            "linux-oracle-tools-5.15.0-1044": "5.15.0-1044.50",
            "linux-oracle": "5.15.0.1044.39",
            "linux-image-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-buildinfo-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-modules-extra-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-oracle-lts-22.04": "5.15.0.1044.39",
            "linux-headers-oracle": "5.15.0.1044.39",
            "linux-image-unsigned-5.15.0-1044-oracle": "5.15.0-1044.50",
            "linux-image-oracle": "5.15.0.1044.39",
            "linux-tools-oracle": "5.15.0.1044.39"
        }
    ]
}