USN-6390-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6390-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6390-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6390-1
Related
Published
2023-09-20T14:07:21.593645Z
Modified
2023-09-20T14:07:21.593645Z
Summary
bind9 vulnerabilities
Details

It was discovered that Bind incorrectly handled certain control channel messages. A remote attacker with access to the control channel could possibly use this issue to cause Bind to crash, resulting in a denial of service. (CVE-2023-3341)

Robert Story discovered that Bind incorrectly handled certain DNS-over-TLS queries. A remote attacker could possibly use this issue to cause Bind to crash, resulting in a denial of service. This issue only affected Ubuntu 22.04 LTS, and Ubuntu 23.04. (CVE-2023-4236)

References

Affected packages

Ubuntu:20.04:LTS / bind9

Package

Name
bind9

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.16.1-0ubuntu2.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "bind9-doc": "1:9.16.1-0ubuntu2.16",
            "bind9utils": "1:9.16.1-0ubuntu2.16",
            "bind9-libs": "1:9.16.1-0ubuntu2.16",
            "bind9": "1:9.16.1-0ubuntu2.16",
            "bind9-utils": "1:9.16.1-0ubuntu2.16",
            "bind9-dnsutils": "1:9.16.1-0ubuntu2.16",
            "bind9-host": "1:9.16.1-0ubuntu2.16",
            "dnsutils": "1:9.16.1-0ubuntu2.16"
        }
    ]
}

Ubuntu:22.04:LTS / bind9

Package

Name
bind9

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.18.12-0ubuntu0.22.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "bind9-doc": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9-dev": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9utils": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9-libs": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9-utils": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9-dnsutils": "1:9.18.12-0ubuntu0.22.04.3",
            "bind9-host": "1:9.18.12-0ubuntu0.22.04.3",
            "dnsutils": "1:9.18.12-0ubuntu0.22.04.3"
        }
    ]
}