USN-6414-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6414-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6414-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6414-2
Related
Published
2023-10-04T22:01:08.590378Z
Modified
2023-10-04T22:01:08.590378Z
Summary
python-django vulnerabilities
Details

USN-6414-1 and USN-6378-1 fixed CVE-2023-43665 and CVE-2023-41164 in Django, respectively. This update provides the corresponding update for Ubuntu 18.04 LTS.

Original advisory details:

Wenchao Li discovered that the Django Truncator function incorrectly handled very long HTML input. A remote attacker could possibly use this issue to cause Django to consume resources, leading to a denial of service.

It was discovered that Django incorrectly handled certain URIs with a very large number of Unicode characters. A remote attacker could possibly use this issue to cause Django to consume resources or crash, leading to a denial of service.

References

Affected packages

Ubuntu:Pro:18.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:1.11.11-1ubuntu1.21+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-django-common": "1:1.11.11-1ubuntu1.21+esm2",
            "python-django-doc": "1:1.11.11-1ubuntu1.21+esm2",
            "python-django": "1:1.11.11-1ubuntu1.21+esm2",
            "python3-django": "1:1.11.11-1ubuntu1.21+esm2"
        }
    ]
}