USN-6424-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6424-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6424-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6424-1
Related
Published
2023-10-10T04:39:08.687692Z
Modified
2023-10-10T04:39:08.687692Z
Summary
ruby-kramdown vulnerability
Details

It was discovered that kramdown did not restrict Rouge formatters to the correct namespace. An attacker could use this issue to cause kramdown to execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / ruby-kramdown

Package

Name
ruby-kramdown

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.17.0-4ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "kramdown": "1.17.0-4ubuntu0.2",
            "ruby-kramdown": "1.17.0-4ubuntu0.2"
        }
    ]
}