USN-6428-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6428-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6428-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6428-1
Related
Published
2023-10-11T03:45:38.744706Z
Modified
2023-10-11T03:45:38.744706Z
Summary
tiff vulnerability
Details

It was discovered that LibTIFF could be made to read out of bounds when processing certain malformed image files with the tiffcrop utility. If a user were tricked into opening a specially crafted image file, an attacker could possibly use this issue to cause tiffcrop to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:Pro:18.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.9-5ubuntu0.10+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libtiff-doc": "4.0.9-5ubuntu0.10+esm3",
            "libtiff-opengl": "4.0.9-5ubuntu0.10+esm3",
            "libtiff5": "4.0.9-5ubuntu0.10+esm3",
            "libtiff-dev": "4.0.9-5ubuntu0.10+esm3",
            "libtiff-tools": "4.0.9-5ubuntu0.10+esm3",
            "libtiffxx5": "4.0.9-5ubuntu0.10+esm3",
            "libtiff5-dev": "4.0.9-5ubuntu0.10+esm3"
        }
    ]
}

Ubuntu:20.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1.0+git191117-2ubuntu0.20.04.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libtiff-doc": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiff-opengl": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiff5": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiff-dev": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiff-tools": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiffxx5": "4.1.0+git191117-2ubuntu0.20.04.10",
            "libtiff5-dev": "4.1.0+git191117-2ubuntu0.20.04.10"
        }
    ]
}

Ubuntu:22.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.3.0-6ubuntu0.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libtiff-doc": "4.3.0-6ubuntu0.6",
            "libtiff-opengl": "4.3.0-6ubuntu0.6",
            "libtiff5": "4.3.0-6ubuntu0.6",
            "libtiff-dev": "4.3.0-6ubuntu0.6",
            "libtiff-tools": "4.3.0-6ubuntu0.6",
            "libtiffxx5": "4.3.0-6ubuntu0.6",
            "libtiff5-dev": "4.3.0-6ubuntu0.6"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.3-7ubuntu0.11+esm10

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libtiff-doc": "4.0.3-7ubuntu0.11+esm10",
            "libtiff-opengl": "4.0.3-7ubuntu0.11+esm10",
            "libtiff4-dev": "4.0.3-7ubuntu0.11+esm10",
            "libtiff5": "4.0.3-7ubuntu0.11+esm10",
            "libtiff5-alt-dev": "4.0.3-7ubuntu0.11+esm10",
            "libtiff-tools": "4.0.3-7ubuntu0.11+esm10",
            "libtiffxx5": "4.0.3-7ubuntu0.11+esm10",
            "libtiff5-dev": "4.0.3-7ubuntu0.11+esm10"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.6-1ubuntu0.8+esm13

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libtiff-doc": "4.0.6-1ubuntu0.8+esm13",
            "libtiff5": "4.0.6-1ubuntu0.8+esm13",
            "libtiff-opengl": "4.0.6-1ubuntu0.8+esm13",
            "libtiff-tools": "4.0.6-1ubuntu0.8+esm13",
            "libtiffxx5": "4.0.6-1ubuntu0.8+esm13",
            "libtiff5-dev": "4.0.6-1ubuntu0.8+esm13"
        }
    ]
}