USN-6429-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6429-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6429-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6429-2
Related
Published
2023-10-11T15:17:59.570820Z
Modified
2023-10-11T15:17:59.570820Z
Summary
curl vulnerability
Details

USN-6429-1 fixed a vulnerability in curl. This update provides the corresponding update for Ubuntu 14.04 LTS, Ubuntu 16.04 LTS and Ubuntu 18.04 LTS.

Original advisory details:

It was discovered that curl incorrectly handled cookies when an application duplicated certain handles. A local attacker could possibly create a cookie file and inject arbitrary cookies into subsequent connections. (CVE-2023-38546)

References

Affected packages

Ubuntu:Pro:18.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.58.0-2ubuntu3.24+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.58.0-2ubuntu3.24+esm2",
            "libcurl4": "7.58.0-2ubuntu3.24+esm2",
            "libcurl4-gnutls-dev": "7.58.0-2ubuntu3.24+esm2",
            "libcurl3-gnutls": "7.58.0-2ubuntu3.24+esm2",
            "libcurl4-doc": "7.58.0-2ubuntu3.24+esm2",
            "libcurl3-nss": "7.58.0-2ubuntu3.24+esm2",
            "libcurl4-nss-dev": "7.58.0-2ubuntu3.24+esm2",
            "libcurl4-openssl-dev": "7.58.0-2ubuntu3.24+esm2"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.20+esm17

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.35.0-1ubuntu2.20+esm17",
            "libcurl3": "7.35.0-1ubuntu2.20+esm17",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.20+esm17",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.20+esm17",
            "libcurl4-doc": "7.35.0-1ubuntu2.20+esm17",
            "libcurl3-nss": "7.35.0-1ubuntu2.20+esm17",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.20+esm17",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.20+esm17"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.19+esm10

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.19+esm10",
            "libcurl3": "7.47.0-1ubuntu2.19+esm10",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.19+esm10",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.19+esm10",
            "libcurl4-doc": "7.47.0-1ubuntu2.19+esm10",
            "libcurl3-nss": "7.47.0-1ubuntu2.19+esm10",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.19+esm10",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.19+esm10"
        }
    ]
}