USN-6431-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6431-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6431-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6431-2
Related
Published
2023-10-16T14:15:08.425534Z
Modified
2023-10-16T14:15:08.425534Z
Summary
iperf3 vulnerability
Details

USN-6431-1 fixed a vulnerability in iperf3. This update provides the corresponding update for Ubuntu 22.04 LTS and Ubuntu 23.04.

Original advisory details:

It was discovered that iperf3 did not properly manage certain inputs, which could lead to a crash. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2023-38403)

References

Affected packages

Ubuntu:22.04:LTS / iperf3

Package

Name
iperf3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.9-1+deb11u1build0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libiperf0": "3.9-1+deb11u1build0.22.04.1",
            "iperf3": "3.9-1+deb11u1build0.22.04.1",
            "libiperf-dev": "3.9-1+deb11u1build0.22.04.1"
        }
    ]
}