USN-6432-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6432-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6432-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6432-1
Related
Published
2023-10-17T10:25:58.828334Z
Modified
2023-10-17T10:25:58.828334Z
Summary
quagga vulnerabilities
Details

It was discovered that the Quagga BGP daemon did not properly check the attribute length in NRLI. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2023-41358)

It was discovered that the Quagga BGP daemon did not properly manage memory when reading initial bytes of ORF header. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2023-41360)

References

Affected packages

Ubuntu:Pro:18.04:LTS / quagga

Package

Name
quagga

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.4-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "quagga-bgpd": "1.2.4-1ubuntu0.1~esm1",
            "quagga": "1.2.4-1ubuntu0.1~esm1",
            "quagga-ospf6d": "1.2.4-1ubuntu0.1~esm1",
            "quagga-ripd": "1.2.4-1ubuntu0.1~esm1",
            "quagga-pimd": "1.2.4-1ubuntu0.1~esm1",
            "quagga-ospfd": "1.2.4-1ubuntu0.1~esm1",
            "quagga-core": "1.2.4-1ubuntu0.1~esm1",
            "quagga-ripngd": "1.2.4-1ubuntu0.1~esm1",
            "quagga-isisd": "1.2.4-1ubuntu0.1~esm1",
            "quagga-doc": "1.2.4-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / quagga

Package

Name
quagga

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.4-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "quagga-bgpd": "1.2.4-4ubuntu0.1",
            "quagga": "1.2.4-4ubuntu0.1",
            "quagga-ospf6d": "1.2.4-4ubuntu0.1",
            "quagga-ripd": "1.2.4-4ubuntu0.1",
            "quagga-pimd": "1.2.4-4ubuntu0.1",
            "quagga-ospfd": "1.2.4-4ubuntu0.1",
            "quagga-core": "1.2.4-4ubuntu0.1",
            "quagga-ripngd": "1.2.4-4ubuntu0.1",
            "quagga-isisd": "1.2.4-4ubuntu0.1",
            "quagga-doc": "1.2.4-4ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / quagga

Package

Name
quagga

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.24.1-2ubuntu1.4+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "quagga": "0.99.24.1-2ubuntu1.4+esm1",
            "quagga-doc": "0.99.24.1-2ubuntu1.4+esm1"
        }
    ]
}