USN-6435-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6435-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6435-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6435-2
Related
Published
2023-10-25T12:40:20.924657Z
Modified
2023-10-25T12:40:20.924657Z
Summary
openssl vulnerabilities
Details

USN-6435-1 fixed vulnerabilities in OpenSSL. This update provides the corresponding updates for Ubuntu 20.04 LTS.

Original advisory details:

It was discovered that OpenSSL incorrectly handled excessively large Diffie-Hellman parameters. An attacker could possibly use this issue to cause a denial of service. (CVE-2023-3446)

Bernd Edlinger discovered that OpenSSL incorrectly handled excessively large Diffie-Hellman parameters. An attacker could possibly use this issue to cause a denial of service. (CVE-2023-3817)

References

Affected packages

Ubuntu:20.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1f-1ubuntu2.20

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.1.1f-1ubuntu2.20",
            "libssl-doc": "1.1.1f-1ubuntu2.20",
            "libssl1.1": "1.1.1f-1ubuntu2.20",
            "openssl": "1.1.1f-1ubuntu2.20"
        }
    ]
}