USN-6443-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6443-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6443-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6443-1
Related
  • CVE-2023-42752
  • CVE-2023-42755
  • CVE-2023-42756
  • CVE-2023-4881
  • CVE-2023-5197
Published
2023-10-19T22:22:42Z
Modified
2023-10-19T22:22:42Z
Summary
linux-oem-6.1 vulnerabilities
Details

Kyle Zeng discovered that the networking stack implementation in the Linux kernel did not properly validate skb object size in certain conditions. An attacker could use this cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-42752)

Kyle Zeng discovered that the IPv4 Resource Reservation Protocol (RSVP) classifier implementation in the Linux kernel contained an out-of-bounds read vulnerability. A local attacker could use this to cause a denial of service (system crash). Please note that kernel packet classifier support for RSVP has been removed to resolve this vulnerability. (CVE-2023-42755)

Kyle Zeng discovered that the netfilter subsystem in the Linux kernel contained a race condition in IP set operations in certain situations. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-42756)

Alex Birnberg discovered that the netfilter subsystem in the Linux kernel did not properly validate register length, leading to an out-of- bounds write vulnerability. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2023-4881)

Kevin Rich discovered that the netfilter subsystem in the Linux kernel did not properly handle removal of rules from chain bindings in certain circumstances, leading to a use-after-free vulnerability. A local attacker could possibly use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2023-5197)

References

Affected packages

Ubuntu:22.04:LTS / linux-oem-6.1

Package

Name
linux-oem-6.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.1.0-1024.24

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-ipu6-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-image-oem-22.04b": "6.1.0.1024.25",
            "linux-tools-oem-22.04b": "6.1.0.1024.25",
            "linux-modules-ipu6-oem-22.04": "6.1.0.1024.25",
            "linux-headers-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-headers-oem-22.04b": "6.1.0.1024.25",
            "linux-image-oem-22.04c": "6.1.0.1024.25",
            "linux-modules-ivsc-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-modules-iwlwifi-oem-22.04": "6.1.0.1024.25",
            "linux-oem-6.1-tools-host": "6.1.0-1024.24",
            "linux-oem-6.1-tools-6.1.0-1024": "6.1.0-1024.24",
            "linux-modules-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-modules-ivsc-oem-22.04": "6.1.0.1024.25",
            "linux-tools-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-headers-oem-22.04a": "6.1.0.1024.25",
            "linux-modules-ivsc-oem-22.04c": "6.1.0.1024.25",
            "linux-modules-ipu6-oem-22.04c": "6.1.0.1024.25",
            "linux-image-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-image-oem-22.04": "6.1.0.1024.25",
            "linux-modules-iwlwifi-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-modules-ipu6-oem-22.04b": "6.1.0.1024.25",
            "linux-modules-iwlwifi-oem-22.04c": "6.1.0.1024.25",
            "linux-oem-22.04b": "6.1.0.1024.25",
            "linux-tools-oem-22.04c": "6.1.0.1024.25",
            "linux-oem-22.04a": "6.1.0.1024.25",
            "linux-buildinfo-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-headers-oem-22.04c": "6.1.0.1024.25",
            "linux-tools-oem-22.04a": "6.1.0.1024.25",
            "linux-oem-22.04c": "6.1.0.1024.25",
            "linux-headers-oem-22.04": "6.1.0.1024.25",
            "linux-modules-iwlwifi-oem-22.04b": "6.1.0.1024.25",
            "linux-modules-ivsc-oem-22.04b": "6.1.0.1024.25",
            "linux-tools-oem-22.04": "6.1.0.1024.25",
            "linux-oem-22.04": "6.1.0.1024.25",
            "linux-image-oem-22.04a": "6.1.0.1024.25",
            "linux-image-unsigned-6.1.0-1024-oem": "6.1.0-1024.24",
            "linux-oem-6.1-headers-6.1.0-1024": "6.1.0-1024.24"
        }
    ]
}