USN-6462-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6462-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6462-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6462-1
Related
  • CVE-2023-0597
  • CVE-2023-31083
  • CVE-2023-3772
  • CVE-2023-4132
Published
2023-10-31T14:45:57.441586Z
Modified
2023-10-31T14:45:57.441586Z
Summary
linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-5.4, linux-bluefield, linux-gcp, linux-gcp-5.4, linux-gkeop, linux-hwe-5.4, linux-ibm, linux-ibm-5.4, linux-kvm, linux-oracle, linux-oracle-5.4, linux-raspi, linux-raspi-5.4, linux-xilinx-zynqmp vulnerabilities
Details

Seth Jenkins discovered that the Linux kernel did not properly perform address randomization for a per-cpu memory management structure. A local attacker could use this to expose sensitive information (kernel memory) or in conjunction with another kernel vulnerability. (CVE-2023-0597)

Yu Hao and Weiteng Chen discovered that the Bluetooth HCI UART driver in the Linux kernel contained a race condition, leading to a null pointer dereference vulnerability. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-31083)

Lin Ma discovered that the Netlink Transformation (XFRM) subsystem in the Linux kernel contained a null pointer dereference vulnerability in some situations. A local privileged attacker could use this to cause a denial of service (system crash). (CVE-2023-3772)

It was discovered that the Siano USB MDTV receiver device driver in the Linux kernel did not properly handle device initialization failures in certain situations, leading to a use-after-free vulnerability. A physically proximate attacker could use this cause a denial of service (system crash). (CVE-2023-4132)

References

Affected packages

Ubuntu:Pro:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1113.123~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-aws-5.4-headers-5.4.0-1113": "5.4.0-1113.123~18.04.1",
            "linux-aws-5.4-cloud-tools-5.4.0-1113": "5.4.0-1113.123~18.04.1",
            "linux-image-aws-edge": "5.4.0.1113.91",
            "linux-headers-aws": "5.4.0.1113.91",
            "linux-image-unsigned-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-buildinfo-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-modules-extra-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-image-aws": "5.4.0.1113.91",
            "linux-aws-5.4-tools-5.4.0-1113": "5.4.0-1113.123~18.04.1",
            "linux-headers-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-tools-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-headers-aws-edge": "5.4.0.1113.91",
            "linux-modules-extra-aws": "5.4.0.1113.91",
            "linux-modules-extra-aws-edge": "5.4.0.1113.91",
            "linux-tools-aws-edge": "5.4.0.1113.91",
            "linux-aws": "5.4.0.1113.91",
            "linux-image-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-aws-edge": "5.4.0.1113.91",
            "linux-cloud-tools-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-modules-5.4.0-1113-aws": "5.4.0-1113.123~18.04.1",
            "linux-tools-aws": "5.4.0.1113.91"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1119.126~18.04.2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-image-azure-edge": "5.4.0.1119.92",
            "linux-modules-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-signed-image-azure": "5.4.0.1119.92",
            "linux-image-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-azure": "5.4.0.1119.92",
            "linux-cloud-tools-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-modules-extra-azure": "5.4.0.1119.92",
            "linux-signed-azure": "5.4.0.1119.92",
            "linux-azure-edge": "5.4.0.1119.92",
            "linux-headers-azure-edge": "5.4.0.1119.92",
            "linux-azure-5.4-headers-5.4.0-1119": "5.4.0-1119.126~18.04.2",
            "linux-headers-azure": "5.4.0.1119.92",
            "linux-cloud-tools-azure-edge": "5.4.0.1119.92",
            "linux-cloud-tools-azure": "5.4.0.1119.92",
            "linux-tools-azure": "5.4.0.1119.92",
            "linux-buildinfo-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-azure-5.4-cloud-tools-5.4.0-1119": "5.4.0-1119.126~18.04.2",
            "linux-image-unsigned-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-image-azure": "5.4.0.1119.92",
            "linux-tools-azure-edge": "5.4.0.1119.92",
            "linux-signed-image-azure-edge": "5.4.0.1119.92",
            "linux-signed-azure-edge": "5.4.0.1119.92",
            "linux-tools-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-headers-5.4.0-1119-azure": "5.4.0-1119.126~18.04.2",
            "linux-azure-5.4-tools-5.4.0-1119": "5.4.0-1119.126~18.04.2",
            "linux-modules-extra-azure-edge": "5.4.0.1119.92"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1117.126~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-tools-gcp": "5.4.0.1117.93",
            "linux-image-unsigned-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-image-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-gcp-5.4-tools-5.4.0-1117": "5.4.0-1117.126~18.04.1",
            "linux-headers-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-headers-gcp-edge": "5.4.0.1117.93",
            "linux-gcp": "5.4.0.1117.93",
            "linux-tools-gcp-edge": "5.4.0.1117.93",
            "linux-image-gcp-edge": "5.4.0.1117.93",
            "linux-tools-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-headers-gcp": "5.4.0.1117.93",
            "linux-gcp-5.4-headers-5.4.0-1117": "5.4.0-1117.126~18.04.1",
            "linux-modules-extra-gcp": "5.4.0.1117.93",
            "linux-gcp-edge": "5.4.0.1117.93",
            "linux-modules-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-modules-extra-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1",
            "linux-modules-extra-gcp-edge": "5.4.0.1117.93",
            "linux-image-gcp": "5.4.0.1117.93",
            "linux-buildinfo-5.4.0-1117-gcp": "5.4.0-1117.126~18.04.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-166.183~18.04.2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-headers-oem": "5.4.0.166.183~18.04.134",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-snapdragon-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-lowlatency-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-buildinfo-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-buildinfo-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-cloud-tools-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-snapdragon-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-snapdragon-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-generic-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-tools-snapdragon-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-oem": "5.4.0.166.183~18.04.134",
            "linux-image-unsigned-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-hwe-5.4-cloud-tools-5.4.0-166": "5.4.0-166.183~18.04.2",
            "linux-modules-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-hwe-5.4-cloud-tools-common": "5.4.0-166.183~18.04.2",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-tools-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-hwe-5.4-tools-5.4.0-166": "5.4.0-166.183~18.04.2",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-modules-extra-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-generic-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-snapdragon-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-modules-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-headers-oem-osp1": "5.4.0.166.183~18.04.134",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-hwe-5.4-source-5.4.0": "5.4.0-166.183~18.04.2",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-headers-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-tools-oem-osp1": "5.4.0.166.183~18.04.134",
            "linux-modules-extra-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-oem-osp1": "5.4.0.166.183~18.04.134",
            "linux-tools-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-tools-oem": "5.4.0.166.183~18.04.134",
            "linux-cloud-tools-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-oem": "5.4.0.166.183~18.04.134",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-hwe-5.4-tools-common": "5.4.0-166.183~18.04.2",
            "linux-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-image-generic-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.166.183~18.04.134",
            "linux-image-oem-osp1": "5.4.0.166.183~18.04.134",
            "linux-tools-virtual-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-unsigned-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-modules-extra-5.4.0-166-generic": "5.4.0-166.183~18.04.2",
            "linux-headers-5.4.0-166-lowlatency": "5.4.0-166.183~18.04.2",
            "linux-hwe-5.4-headers-5.4.0-166": "5.4.0-166.183~18.04.2",
            "linux-tools-generic-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-tools-snapdragon-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.166.183~18.04.134",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.166.183~18.04.134"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-ibm-5.4

Package

Name
linux-ibm-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1060.65~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-tools-ibm-edge": "5.4.0.1060.71",
            "linux-ibm-5.4-headers-5.4.0-1060": "5.4.0-1060.65~18.04.1",
            "linux-modules-extra-ibm": "5.4.0.1060.71",
            "linux-image-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-headers-ibm-edge": "5.4.0.1060.71",
            "linux-tools-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-modules-extra-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-ibm-5.4-tools-common": "5.4.0-1060.65~18.04.1",
            "linux-modules-extra-ibm-edge": "5.4.0.1060.71",
            "linux-tools-ibm": "5.4.0.1060.71",
            "linux-ibm-edge": "5.4.0.1060.71",
            "linux-headers-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-ibm": "5.4.0.1060.71",
            "linux-headers-ibm": "5.4.0.1060.71",
            "linux-image-unsigned-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-buildinfo-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-ibm-5.4-cloud-tools-common": "5.4.0-1060.65~18.04.1",
            "linux-ibm-5.4-tools-5.4.0-1060": "5.4.0-1060.65~18.04.1",
            "linux-image-ibm-edge": "5.4.0.1060.71",
            "linux-image-ibm": "5.4.0.1060.71",
            "linux-modules-5.4.0-1060-ibm": "5.4.0-1060.65~18.04.1",
            "linux-ibm-5.4-source-5.4.0": "5.4.0-1060.65~18.04.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1112.121~18.04.4

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-modules-extra-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-headers-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-buildinfo-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-tools-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-headers-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-oracle-5.4-tools-5.4.0-1112": "5.4.0-1112.121~18.04.4",
            "linux-modules-extra-oracle": "5.4.0.1112.121~18.04.84",
            "linux-signed-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-oracle-5.4-headers-5.4.0-1112": "5.4.0-1112.121~18.04.4",
            "linux-tools-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-oracle": "5.4.0.1112.121~18.04.84",
            "linux-signed-oracle": "5.4.0.1112.121~18.04.84",
            "linux-signed-image-oracle": "5.4.0.1112.121~18.04.84",
            "linux-modules-extra-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-modules-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-headers-oracle": "5.4.0.1112.121~18.04.84",
            "linux-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-image-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-signed-image-oracle-edge": "5.4.0.1112.121~18.04.84",
            "linux-image-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4",
            "linux-tools-oracle": "5.4.0.1112.121~18.04.84",
            "linux-image-oracle": "5.4.0.1112.121~18.04.84",
            "linux-image-unsigned-5.4.0-1112-oracle": "5.4.0-1112.121~18.04.4"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-raspi-5.4

Package

Name
linux-raspi-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1097.109~18.04.2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1097.94",
            "linux-buildinfo-5.4.0-1097-raspi": "5.4.0-1097.109~18.04.2",
            "linux-modules-5.4.0-1097-raspi": "5.4.0-1097.109~18.04.2",
            "linux-tools-5.4.0-1097-raspi": "5.4.0-1097.109~18.04.2",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1097.94",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1097.94",
            "linux-raspi-5.4-headers-5.4.0-1097": "5.4.0-1097.109~18.04.2",
            "linux-headers-5.4.0-1097-raspi": "5.4.0-1097.109~18.04.2",
            "linux-image-raspi-hwe-18.04": "5.4.0.1097.94",
            "linux-raspi-hwe-18.04": "5.4.0.1097.94",
            "linux-raspi-5.4-tools-5.4.0-1097": "5.4.0-1097.109~18.04.2",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1097.94",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1097.94",
            "linux-image-5.4.0-1097-raspi": "5.4.0-1097.109~18.04.2",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1097.94"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-166.183

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.166.163",
            "linux-headers-oem": "5.4.0.166.163",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-lowlatency-hwe-18.04": "5.4.0.166.163",
            "linux-buildinfo-5.4.0-166-generic": "5.4.0-166.183",
            "linux-buildinfo-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-cloud-tools-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.166.163",
            "linux-cloud-tools-virtual": "5.4.0.166.163",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.166.163",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.166.163",
            "linux-headers-generic-hwe-18.04": "5.4.0.166.163",
            "linux-generic-lpae-hwe-18.04": "5.4.0.166.163",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.166.163",
            "linux-tools-virtual": "5.4.0.166.163",
            "linux-oem-osp1-tools-host": "5.4.0.166.163",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.166.163",
            "linux-image-5.4.0-166-generic": "5.4.0-166.183",
            "linux-tools-5.4.0-166-generic-lpae": "5.4.0-166.183",
            "linux-source": "5.4.0.166.163",
            "linux-image-extra-virtual": "5.4.0.166.163",
            "linux-oem": "5.4.0.166.163",
            "linux-headers-5.4.0-166-generic": "5.4.0-166.183",
            "linux-cloud-tools-generic": "5.4.0.166.163",
            "linux-image-virtual": "5.4.0.166.163",
            "linux-image-unsigned-5.4.0-166-generic": "5.4.0-166.183",
            "linux-tools-generic": "5.4.0.166.163",
            "linux-modules-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-cloud-tools-lowlatency": "5.4.0.166.163",
            "linux-generic-lpae": "5.4.0.166.163",
            "linux-virtual": "5.4.0.166.163",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.166.163",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.166.163",
            "linux-image-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-crashdump": "5.4.0.166.163",
            "linux-generic": "5.4.0.166.163",
            "linux-tools-5.4.0-166-generic": "5.4.0-166.183",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.166.163",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.166.163",
            "linux-generic-hwe-18.04-edge": "5.4.0.166.163",
            "linux-headers-generic-lpae": "5.4.0.166.163",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-generic-lpae": "5.4.0.166.163",
            "linux-headers-5.4.0-166-generic-lpae": "5.4.0-166.183",
            "linux-cloud-tools-5.4.0-166": "5.4.0-166.183",
            "linux-tools-lowlatency": "5.4.0.166.163",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.166.163",
            "linux-cloud-tools-common": "5.4.0-166.183",
            "linux-modules-5.4.0-166-generic": "5.4.0-166.183",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.166.163",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.166.163",
            "linux-libc-dev": "5.4.0-166.183",
            "linux-source-5.4.0": "5.4.0-166.183",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-doc": "5.4.0-166.183",
            "linux-headers-virtual-hwe-18.04": "5.4.0.166.163",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.166.163",
            "linux-tools-oem-osp1": "5.4.0.166.163",
            "linux-oem-osp1": "5.4.0.166.163",
            "linux-tools-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-headers-oem-osp1": "5.4.0.166.163",
            "linux-headers-generic": "5.4.0.166.163",
            "linux-tools-oem": "5.4.0.166.163",
            "linux-headers-lowlatency": "5.4.0.166.163",
            "linux-oem-tools-host": "5.4.0.166.163",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.166.163",
            "linux-headers-virtual": "5.4.0.166.163",
            "linux-cloud-tools-5.4.0-166-generic": "5.4.0-166.183",
            "linux-virtual-hwe-18.04": "5.4.0.166.163",
            "linux-image-oem": "5.4.0.166.163",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-lowlatency": "5.4.0.166.163",
            "linux-tools-host": "5.4.0-166.183",
            "linux-headers-5.4.0-166": "5.4.0-166.183",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.166.163",
            "linux-tools-5.4.0-166": "5.4.0-166.183",
            "linux-image-5.4.0-166-generic-lpae": "5.4.0-166.183",
            "linux-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-image-generic-hwe-18.04": "5.4.0.166.163",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.166.163",
            "linux-image-virtual-hwe-18.04": "5.4.0.166.163",
            "linux-tools-generic-lpae": "5.4.0.166.163",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.166.163",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.166.163",
            "linux-tools-virtual-hwe-18.04": "5.4.0.166.163",
            "linux-image-unsigned-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-image-oem-osp1": "5.4.0.166.163",
            "linux-modules-extra-5.4.0-166-generic": "5.4.0-166.183",
            "linux-headers-5.4.0-166-lowlatency": "5.4.0-166.183",
            "linux-modules-5.4.0-166-generic-lpae": "5.4.0-166.183",
            "linux-tools-common": "5.4.0-166.183",
            "linux-tools-generic-hwe-18.04": "5.4.0.166.163",
            "linux-image-generic": "5.4.0.166.163",
            "linux-lowlatency": "5.4.0.166.163",
            "linux-buildinfo-5.4.0-166-generic-lpae": "5.4.0-166.183",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.166.163",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.166.163"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1113.123

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-modules-extra-aws-lts-20.04": "5.4.0.1113.110",
            "linux-image-unsigned-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-modules-extra-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-buildinfo-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-tools-aws-lts-20.04": "5.4.0.1113.110",
            "linux-aws-lts-20.04": "5.4.0.1113.110",
            "linux-headers-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-headers-aws-lts-20.04": "5.4.0.1113.110",
            "linux-tools-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-aws-cloud-tools-5.4.0-1113": "5.4.0-1113.123",
            "linux-image-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-aws-tools-5.4.0-1113": "5.4.0-1113.123",
            "linux-cloud-tools-5.4.0-1113-aws": "5.4.0-1113.123",
            "linux-image-aws-lts-20.04": "5.4.0.1113.110",
            "linux-aws-headers-5.4.0-1113": "5.4.0-1113.123"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1119.126

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-image-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-tools-azure-lts-20.04": "5.4.0.1119.112",
            "linux-cloud-tools-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-modules-extra-azure-lts-20.04": "5.4.0.1119.112",
            "linux-azure-headers-5.4.0-1119": "5.4.0-1119.126",
            "linux-azure-tools-5.4.0-1119": "5.4.0-1119.126",
            "linux-image-azure-lts-20.04": "5.4.0.1119.112",
            "linux-headers-azure-lts-20.04": "5.4.0.1119.112",
            "linux-buildinfo-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-cloud-tools-azure-lts-20.04": "5.4.0.1119.112",
            "linux-image-unsigned-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-azure-cloud-tools-5.4.0-1119": "5.4.0-1119.126",
            "linux-azure-lts-20.04": "5.4.0.1119.112",
            "linux-tools-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-headers-5.4.0-1119-azure": "5.4.0-1119.126",
            "linux-modules-extra-5.4.0-1119-azure": "5.4.0-1119.126"
        }
    ]
}

Ubuntu:20.04:LTS / linux-bluefield

Package

Name
linux-bluefield

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1074.80

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-modules-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-bluefield-headers-5.4.0-1074": "5.4.0-1074.80",
            "linux-headers-bluefield": "5.4.0.1074.69",
            "linux-bluefield-tools-5.4.0-1074": "5.4.0-1074.80",
            "linux-tools-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-tools-bluefield": "5.4.0.1074.69",
            "linux-image-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-image-bluefield": "5.4.0.1074.69",
            "linux-buildinfo-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-image-unsigned-5.4.0-1074-bluefield": "5.4.0-1074.80",
            "linux-bluefield": "5.4.0.1074.69"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1117.126

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-image-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-modules-extra-gcp-lts-20.04": "5.4.0.1117.119",
            "linux-headers-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-image-gcp-lts-20.04": "5.4.0.1117.119",
            "linux-gcp-headers-5.4.0-1117": "5.4.0-1117.126",
            "linux-tools-gcp-lts-20.04": "5.4.0.1117.119",
            "linux-tools-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-modules-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-modules-extra-5.4.0-1117-gcp": "5.4.0-1117.126",
            "linux-headers-gcp-lts-20.04": "5.4.0.1117.119",
            "linux-gcp-tools-5.4.0-1117": "5.4.0-1117.126",
            "linux-gcp-lts-20.04": "5.4.0.1117.119",
            "linux-buildinfo-5.4.0-1117-gcp": "5.4.0-1117.126"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gkeop

Package

Name
linux-gkeop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1080.84

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-headers-gkeop": "5.4.0.1080.78",
            "linux-gkeop-5.4": "5.4.0.1080.78",
            "linux-headers-gkeop-5.4": "5.4.0.1080.78",
            "linux-tools-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-modules-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-cloud-tools-gkeop": "5.4.0.1080.78",
            "linux-gkeop": "5.4.0.1080.78",
            "linux-modules-extra-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-tools-gkeop": "5.4.0.1080.78",
            "linux-image-gkeop-5.4": "5.4.0.1080.78",
            "linux-modules-extra-gkeop": "5.4.0.1080.78",
            "linux-gkeop-cloud-tools-5.4.0-1080": "5.4.0-1080.84",
            "linux-image-gkeop": "5.4.0.1080.78",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1080.78",
            "linux-gkeop-source-5.4.0": "5.4.0-1080.84",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1080.78",
            "linux-cloud-tools-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-buildinfo-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-gkeop-tools-5.4.0-1080": "5.4.0-1080.84",
            "linux-gkeop-headers-5.4.0-1080": "5.4.0-1080.84",
            "linux-tools-gkeop-5.4": "5.4.0.1080.78",
            "linux-image-unsigned-5.4.0-1080-gkeop": "5.4.0-1080.84",
            "linux-image-5.4.0-1080-gkeop": "5.4.0-1080.84"
        }
    ]
}

Ubuntu:20.04:LTS / linux-ibm

Package

Name
linux-ibm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1060.65

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-ibm-lts-20.04": "5.4.0.1060.89",
            "linux-tools-ibm-lts-20.04": "5.4.0.1060.89",
            "linux-image-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-ibm-headers-5.4.0-1060": "5.4.0-1060.65",
            "linux-ibm-tools-5.4.0-1060": "5.4.0-1060.65",
            "linux-tools-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-modules-extra-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-ibm-lts-20.04": "5.4.0.1060.89",
            "linux-ibm-tools-common": "5.4.0-1060.65",
            "linux-headers-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-modules-extra-ibm-lts-20.04": "5.4.0.1060.89",
            "linux-image-unsigned-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-buildinfo-5.4.0-1060-ibm": "5.4.0-1060.65",
            "linux-image-ibm-lts-20.04": "5.4.0.1060.89",
            "linux-ibm-source-5.4.0": "5.4.0-1060.65",
            "linux-ibm-cloud-tools-common": "5.4.0-1060.65",
            "linux-modules-5.4.0-1060-ibm": "5.4.0-1060.65"
        }
    ]
}

Ubuntu:20.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1102.108

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-kvm": "5.4.0.1102.97",
            "linux-kvm": "5.4.0.1102.97",
            "linux-kvm-tools-5.4.0-1102": "5.4.0-1102.108",
            "linux-kvm-headers-5.4.0-1102": "5.4.0-1102.108",
            "linux-tools-kvm": "5.4.0.1102.97",
            "linux-image-unsigned-5.4.0-1102-kvm": "5.4.0-1102.108",
            "linux-tools-5.4.0-1102-kvm": "5.4.0-1102.108",
            "linux-image-5.4.0-1102-kvm": "5.4.0-1102.108",
            "linux-headers-5.4.0-1102-kvm": "5.4.0-1102.108",
            "linux-buildinfo-5.4.0-1102-kvm": "5.4.0-1102.108",
            "linux-image-kvm": "5.4.0.1102.97",
            "linux-modules-5.4.0-1102-kvm": "5.4.0-1102.108"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1112.121

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oracle-headers-5.4.0-1112": "5.4.0-1112.121",
            "linux-image-oracle-lts-20.04": "5.4.0.1112.105",
            "linux-buildinfo-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-oracle-lts-20.04": "5.4.0.1112.105",
            "linux-headers-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-headers-oracle-lts-20.04": "5.4.0.1112.105",
            "linux-modules-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-modules-extra-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-tools-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-image-5.4.0-1112-oracle": "5.4.0-1112.121",
            "linux-oracle-tools-5.4.0-1112": "5.4.0-1112.121",
            "linux-tools-oracle-lts-20.04": "5.4.0.1112.105",
            "linux-image-unsigned-5.4.0-1112-oracle": "5.4.0-1112.121"
        }
    ]
}

Ubuntu:20.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1097.109

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-buildinfo-5.4.0-1097-raspi": "5.4.0-1097.109",
            "linux-headers-raspi": "5.4.0.1097.127",
            "linux-image-raspi2": "5.4.0.1097.127",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-headers-5.4.0-1097-raspi": "5.4.0-1097.109",
            "linux-raspi-headers-5.4.0-1097": "5.4.0-1097.109",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1097.127",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-raspi2-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-headers-raspi2-hwe-18.04": "5.4.0.1097.127",
            "linux-raspi-tools-5.4.0-1097": "5.4.0-1097.109",
            "linux-image-raspi": "5.4.0.1097.127",
            "linux-image-raspi2-hwe-18.04": "5.4.0.1097.127",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-tools-raspi2-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-headers-raspi2-hwe-18.04-edge": "5.4.0.1097.127",
            "linux-modules-5.4.0-1097-raspi": "5.4.0-1097.109",
            "linux-tools-raspi": "5.4.0.1097.127",
            "linux-tools-5.4.0-1097-raspi": "5.4.0-1097.109",
            "linux-tools-raspi2-hwe-18.04": "5.4.0.1097.127",
            "linux-raspi2-hwe-18.04": "5.4.0.1097.127",
            "linux-raspi": "5.4.0.1097.127",
            "linux-raspi-hwe-18.04": "5.4.0.1097.127",
            "linux-headers-raspi2": "5.4.0.1097.127",
            "linux-tools-raspi2": "5.4.0.1097.127",
            "linux-image-raspi-hwe-18.04": "5.4.0.1097.127",
            "linux-raspi2": "5.4.0.1097.127",
            "linux-image-5.4.0-1097-raspi": "5.4.0-1097.109",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1097.127"
        }
    ]
}

Ubuntu:20.04:LTS / linux-xilinx-zynqmp

Package

Name
linux-xilinx-zynqmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1033.37

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1033-xilinx-zynqmp": "5.4.0-1033.37",
            "linux-headers-xilinx-zynqmp": "5.4.0.1033.33",
            "linux-image-5.4.0-1033-xilinx-zynqmp": "5.4.0-1033.37",
            "linux-image-xilinx-zynqmp": "5.4.0.1033.33",
            "linux-xilinx-zynqmp": "5.4.0.1033.33",
            "linux-xilinx-zynqmp-headers-5.4.0-1033": "5.4.0-1033.37",
            "linux-tools-xilinx-zynqmp": "5.4.0.1033.33",
            "linux-xilinx-zynqmp-tools-5.4.0-1033": "5.4.0-1033.37",
            "linux-modules-5.4.0-1033-xilinx-zynqmp": "5.4.0-1033.37",
            "linux-tools-5.4.0-1033-xilinx-zynqmp": "5.4.0-1033.37",
            "linux-buildinfo-5.4.0-1033-xilinx-zynqmp": "5.4.0-1033.37"
        }
    ]
}