USN-6477-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6477-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6477-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6477-1
Related
Published
2023-11-14T09:44:00.815861Z
Modified
2023-11-14T09:44:00.815861Z
Summary
procps vulnerability
Details

It was discovered that the procps-ng ps tool incorrectly handled memory. An attacker could possibly use this issue to cause procps-ng to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:Pro:18.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.12-3ubuntu1.2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libprocps-dev": "2:3.3.12-3ubuntu1.2+esm1",
            "libprocps6": "2:3.3.12-3ubuntu1.2+esm1",
            "procps": "2:3.3.12-3ubuntu1.2+esm1"
        }
    ]
}

Ubuntu:20.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.16-1ubuntu2.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libprocps-dev": "2:3.3.16-1ubuntu2.4",
            "libprocps8": "2:3.3.16-1ubuntu2.4",
            "procps": "2:3.3.16-1ubuntu2.4"
        }
    ]
}

Ubuntu:22.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.17-6ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libprocps-dev": "2:3.3.17-6ubuntu2.1",
            "libprocps8": "2:3.3.17-6ubuntu2.1",
            "procps": "2:3.3.17-6ubuntu2.1"
        }
    ]
}

Ubuntu:23.10 / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:4.0.3-1ubuntu1.23.10.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libproc2-dev": "2:4.0.3-1ubuntu1.23.10.1",
            "procps": "2:4.0.3-1ubuntu1.23.10.1",
            "libproc2-0": "2:4.0.3-1ubuntu1.23.10.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.10-4ubuntu2.5+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libprocps4-dev": "2:3.3.10-4ubuntu2.5+esm1",
            "procps": "2:3.3.10-4ubuntu2.5+esm1",
            "libprocps4": "2:3.3.10-4ubuntu2.5+esm1"
        }
    ]
}