USN-6490-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6490-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6490-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6490-1
Related
Published
2023-11-20T15:59:27.780923Z
Modified
2023-11-20T15:59:27.780923Z
Summary
webkit2gtk vulnerabilities
Details

Several security issues were discovered in the WebKitGTK Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

References

Affected packages

Ubuntu:22.04:LTS / webkit2gtk

Package

Name
webkit2gtk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.42.2-0ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libjavascriptcoregtk-6.0-1": "2.42.2-0ubuntu0.22.04.1",
            "libwebkitgtk-6.0-4": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-javascriptcoregtk-4.1": "2.42.2-0ubuntu0.22.04.1",
            "libwebkit2gtk-4.1-dev": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-javascriptcoregtk-4.0": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-4.0-bin": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-4.0-18": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-4.1-dev": "2.42.2-0ubuntu0.22.04.1",
            "libwebkit2gtk-4.0-doc": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-webkit-6.0": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-webkit2-4.1": "2.42.2-0ubuntu0.22.04.1",
            "webkit2gtk-driver": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-webkit2-4.0": "2.42.2-0ubuntu0.22.04.1",
            "libwebkit2gtk-4.0-dev": "2.42.2-0ubuntu0.22.04.1",
            "gir1.2-javascriptcoregtk-6.0": "2.42.2-0ubuntu0.22.04.1",
            "libwebkitgtk-6.0-dev": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-6.0-dev": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-4.0-dev": "2.42.2-0ubuntu0.22.04.1",
            "libwebkit2gtk-4.1-0": "2.42.2-0ubuntu0.22.04.1",
            "libjavascriptcoregtk-4.1-0": "2.42.2-0ubuntu0.22.04.1",
            "libwebkit2gtk-4.0-37": "2.42.2-0ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:23.10 / webkit2gtk

Package

Name
webkit2gtk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.42.2-0ubuntu0.23.10.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libjavascriptcoregtk-6.0-1": "2.42.2-0ubuntu0.23.10.1",
            "libwebkitgtk-6.0-4": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-javascriptcoregtk-4.1": "2.42.2-0ubuntu0.23.10.1",
            "libwebkit2gtk-4.1-dev": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-javascriptcoregtk-4.0": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-4.0-bin": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-4.0-18": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-4.1-dev": "2.42.2-0ubuntu0.23.10.1",
            "libwebkit2gtk-4.0-doc": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-webkit-6.0": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-webkit2-4.1": "2.42.2-0ubuntu0.23.10.1",
            "webkit2gtk-driver": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-webkit2-4.0": "2.42.2-0ubuntu0.23.10.1",
            "libwebkit2gtk-4.0-dev": "2.42.2-0ubuntu0.23.10.1",
            "gir1.2-javascriptcoregtk-6.0": "2.42.2-0ubuntu0.23.10.1",
            "libwebkitgtk-6.0-dev": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-6.0-dev": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-4.0-dev": "2.42.2-0ubuntu0.23.10.1",
            "libwebkit2gtk-4.1-0": "2.42.2-0ubuntu0.23.10.1",
            "libjavascriptcoregtk-4.1-0": "2.42.2-0ubuntu0.23.10.1",
            "libwebkit2gtk-4.0-37": "2.42.2-0ubuntu0.23.10.1"
        }
    ]
}