USN-6491-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6491-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6491-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6491-1
Related
Published
2023-11-21T09:15:47.863866Z
Modified
2023-11-21T09:15:47.863866Z
Summary
nodejs vulnerabilities
Details

Axel Chong discovered that Node.js incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to execute arbitrary code. (CVE-2022-32212)

Zeyu Zhang discovered that Node.js incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-32213, CVE-2022-32214, CVE-2022-32215)

It was discovered that Node.js incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-35256)

It was discovered that Node.js incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-43548)

References

Affected packages

Ubuntu:Pro:18.04:LTS / nodejs

Package

Name
nodejs

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.10.0~dfsg-2ubuntu0.4+esm4

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "nodejs-dev": "8.10.0~dfsg-2ubuntu0.4+esm4",
            "nodejs-doc": "8.10.0~dfsg-2ubuntu0.4+esm4",
            "nodejs": "8.10.0~dfsg-2ubuntu0.4+esm4"
        }
    ]
}

Ubuntu:20.04:LTS / nodejs

Package

Name
nodejs

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.19.0~dfsg-3ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nodejs-doc": "10.19.0~dfsg-3ubuntu1.3",
            "nodejs": "10.19.0~dfsg-3ubuntu1.3",
            "libnode-dev": "10.19.0~dfsg-3ubuntu1.3",
            "libnode64": "10.19.0~dfsg-3ubuntu1.3"
        }
    ]
}

Ubuntu:22.04:LTS / nodejs

Package

Name
nodejs

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.22.9~dfsg-1ubuntu3.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nodejs-doc": "12.22.9~dfsg-1ubuntu3.2",
            "libnode72": "12.22.9~dfsg-1ubuntu3.2",
            "nodejs": "12.22.9~dfsg-1ubuntu3.2",
            "libnode-dev": "12.22.9~dfsg-1ubuntu3.2"
        }
    ]
}