USN-6499-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6499-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6499-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6499-2
Related
Published
2024-01-08T11:39:13.521467Z
Modified
2024-01-08T11:39:13.521467Z
Summary
gnutls28 vulnerability
Details

USN-6499-1 fixed vulnerabilities in GnuTLS. This update provides the corresponding update for Ubuntu 18.04 LTS.

Original advisory details:

It was discovered that GnuTLS had a timing side-channel when handling certain RSA-PSK key exchanges. A remote attacker could possibly use this issue to recover sensitive information.

References

Affected packages

Ubuntu:Pro:18.04:LTS / gnutls28

Package

Name
gnutls28

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.18-1ubuntu1.6+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "gnutls-doc": "3.5.18-1ubuntu1.6+esm1",
            "libgnutls28-dev": "3.5.18-1ubuntu1.6+esm1",
            "libgnutls-dane0": "3.5.18-1ubuntu1.6+esm1",
            "gnutls-bin": "3.5.18-1ubuntu1.6+esm1",
            "libgnutls30": "3.5.18-1ubuntu1.6+esm1",
            "libgnutls-openssl27": "3.5.18-1ubuntu1.6+esm1",
            "libgnutlsxx28": "3.5.18-1ubuntu1.6+esm1"
        }
    ]
}