USN-6538-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6538-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6538-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6538-1
Related
Published
2023-12-06T15:11:27.356147Z
Modified
2023-12-06T15:11:27.356147Z
Summary
postgresql-12, postgresql-14, postgresql-15 vulnerabilities
Details

Jingzhou Fu discovered that PostgreSQL incorrectly handled certain unknown arguments in aggregate function calls. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2023-5868)

Pedro Gallegos discovered that PostgreSQL incorrectly handled modifying certain SQL array values. A remote attacker could use this issue to obtain sensitive information, or possibly execute arbitrary code. (CVE-2023-5869)

Hemanth Sandrana and Mahendrakar Srinivasarao discovered that PostgreSQL allowed the pgsignalbackend role to signal certain superuser processes, contrary to expectations. (CVE-2023-5870)

References

Affected packages

Ubuntu:20.04:LTS / postgresql-12

Package

Name
postgresql-12

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.17-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpgtypes3": "12.17-0ubuntu0.20.04.1",
            "libecpg6": "12.17-0ubuntu0.20.04.1",
            "postgresql-plpython3-12": "12.17-0ubuntu0.20.04.1",
            "postgresql-doc-12": "12.17-0ubuntu0.20.04.1",
            "libpq-dev": "12.17-0ubuntu0.20.04.1",
            "postgresql-pltcl-12": "12.17-0ubuntu0.20.04.1",
            "libecpg-dev": "12.17-0ubuntu0.20.04.1",
            "libecpg-compat3": "12.17-0ubuntu0.20.04.1",
            "libpq5": "12.17-0ubuntu0.20.04.1",
            "postgresql-12": "12.17-0ubuntu0.20.04.1",
            "postgresql-client-12": "12.17-0ubuntu0.20.04.1",
            "postgresql-server-dev-12": "12.17-0ubuntu0.20.04.1",
            "postgresql-plperl-12": "12.17-0ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / postgresql-14

Package

Name
postgresql-14

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
14.10-0ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "postgresql-client-14": "14.10-0ubuntu0.22.04.1",
            "libpgtypes3": "14.10-0ubuntu0.22.04.1",
            "libecpg6": "14.10-0ubuntu0.22.04.1",
            "libpq-dev": "14.10-0ubuntu0.22.04.1",
            "postgresql-doc-14": "14.10-0ubuntu0.22.04.1",
            "postgresql-server-dev-14": "14.10-0ubuntu0.22.04.1",
            "libecpg-dev": "14.10-0ubuntu0.22.04.1",
            "libecpg-compat3": "14.10-0ubuntu0.22.04.1",
            "libpq5": "14.10-0ubuntu0.22.04.1",
            "postgresql-plperl-14": "14.10-0ubuntu0.22.04.1",
            "postgresql-14": "14.10-0ubuntu0.22.04.1",
            "postgresql-pltcl-14": "14.10-0ubuntu0.22.04.1",
            "postgresql-plpython3-14": "14.10-0ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:23.10 / postgresql-15

Package

Name
postgresql-15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
15.5-0ubuntu0.23.10.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "postgresql-plperl-15": "15.5-0ubuntu0.23.10.1",
            "libpgtypes3": "15.5-0ubuntu0.23.10.1",
            "libecpg6": "15.5-0ubuntu0.23.10.1",
            "libpq-dev": "15.5-0ubuntu0.23.10.1",
            "postgresql-server-dev-15": "15.5-0ubuntu0.23.10.1",
            "postgresql-pltcl-15": "15.5-0ubuntu0.23.10.1",
            "postgresql-15": "15.5-0ubuntu0.23.10.1",
            "libecpg-dev": "15.5-0ubuntu0.23.10.1",
            "postgresql-doc-15": "15.5-0ubuntu0.23.10.1",
            "libecpg-compat3": "15.5-0ubuntu0.23.10.1",
            "libpq5": "15.5-0ubuntu0.23.10.1",
            "postgresql-plpython3-15": "15.5-0ubuntu0.23.10.1",
            "postgresql-client-15": "15.5-0ubuntu0.23.10.1"
        }
    ]
}