USN-6551-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6551-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6551-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6551-1
Related
  • CVE-2023-46751
Published
2023-12-12T13:08:30.503366Z
Modified
2023-12-12T13:08:30.503366Z
Summary
ghostscript vulnerability
Details

It was discovered that Ghostscript incorrectly handled writing TIFF files. A remote attacker could possibly use this issue to cause Ghostscript to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:22.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.55.0~dfsg1-0ubuntu5.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ghostscript-doc": "9.55.0~dfsg1-0ubuntu5.6",
            "libgs9-common": "9.55.0~dfsg1-0ubuntu5.6",
            "ghostscript": "9.55.0~dfsg1-0ubuntu5.6",
            "libgs-dev": "9.55.0~dfsg1-0ubuntu5.6",
            "ghostscript-x": "9.55.0~dfsg1-0ubuntu5.6",
            "libgs9": "9.55.0~dfsg1-0ubuntu5.6"
        }
    ]
}

Ubuntu:23.10 / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.01.2~dfsg1-0ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-common": "10.01.2~dfsg1-0ubuntu2.2",
            "ghostscript-doc": "10.01.2~dfsg1-0ubuntu2.2",
            "ghostscript-x": "10.01.2~dfsg1-0ubuntu2.2",
            "libgs-dev": "10.01.2~dfsg1-0ubuntu2.2",
            "libgs9-common": "10.01.2~dfsg1-0ubuntu2.2",
            "ghostscript": "10.01.2~dfsg1-0ubuntu2.2",
            "libgs10": "10.01.2~dfsg1-0ubuntu2.2",
            "libgs10-common": "10.01.2~dfsg1-0ubuntu2.2"
        }
    ]
}